WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26141 closed feature request (duplicate)

complete cache system

Reported by: camaran Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Cache API Keywords:
Focuses: Cc:

Description

add a complete cache system (apc, memecached, ecc...)

Change History (3)

#1 @markoheijnen
7 years ago

I do think we have a complete system except it's missing the actual code to use external caching. Personally I'm fine with how it is right now since I don't use memcached or APC. I use a APCu what is a variant of APC.

So I don't think something like this can be added to core since things will change. There is now memcache and memcached for example and I'm pretty sure that APC will fade away for something like APCu.

#2 @johnbillion
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Rather than trying to implement interfaces to every caching engine under the sun, WordPress instead provides the means for plugins to provide these interfaces.

Alex Mills wrote an article on this a few years ago.

TL;DR: Persistent caching isn’t needed for most sites and is a pain to get working in all hosting environments. Instead WordPress makes it really easy to install a caching plugin if you need it.

There are many plugins in the plugin directory that add support for APC, Memcached, Xcache, static page caching...

#3 @SergeyBiryukov
7 years ago

  • Resolution changed from wontfix to duplicate
  • Version trunk deleted

Duplicate of #17055.

Note: See TracTickets for help on using tickets.