WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26191 closed defect (bug) (fixed)

Twenty Fourteen: swipe touch events on slider have a slight delay

Reported by: sonjanyc Owned by: lancewillett
Milestone: 3.8 Priority: low
Severity: normal Version: 3.8
Component: Bundled Theme Keywords: needs-patch
Focuses: Cc:

Description (last modified by lancewillett)

Slight delay on swipe touch events, like on an iPad or iPhone.

To repeat

  1. Swipe with your finger between slides
  2. Note how the swipe event starts with delay and sometimes overlays a half or less, then stops for a second and then completes to show full next slide.

See example video: http://wpthemetestdata.files.wordpress.com/2013/12/2014-slider-mobile-behavior.mov

Change History (20)

#1 @SergeyBiryukov
7 years ago

  • Component changed from General to Bundled Theme

#2 @lancewillett
7 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.8

#3 @lancewillett
7 years ago

  • Cc Frank Klein added

@Frank Klein is looking at this one.

#4 @lancewillett
7 years ago

  • Priority changed from normal to low

Severity is low on this, nice to fix but not a blocker for 3.8 release.

#5 @lancewillett
7 years ago

  • Summary changed from Twenty Fourteen: homepage slider behavior on mobile starts with delay to Twenty Fourteen: swipe touch events on slider have a slight delay

#6 @bassgang
7 years ago

For the 1. case (swiping) I am not sure,
but probably "FastClick" https://github.com/ftlabs/fastclick could help to solve case 2. and 3. (seems like a normal "click").

#7 @lancewillett
7 years ago

I think cases 2 and 3 are fine -- it's 1 we need to patch.

#8 @kwight
7 years ago

This has been an issue I've noticed with FlexSlider since (I believe) the original pre-WooThemes FlexSlider (v1).

#9 @lancewillett
7 years ago

@kwight Interesting ... good to know. I'll ping the authors to see if they have an opinion. Did you see any open issues in GitHub related to it?

#10 @kwight
7 years ago

No I didn't see anything related, but FlexSlider gets very little love on GitHub (470+ open issues).

#11 @iandstewart
7 years ago

I can't reproduce 2 and 3 on an iPhone 5s using iOS 7.0.4 but do notice a slight delay with swiping in number 1.

Last edited 7 years ago by iandstewart (previous) (diff)

#12 @lancewillett
7 years ago

  • Cc Frank Klein removed
  • Description modified (diff)

#13 @iandstewart
7 years ago

  • Cc Frank Klein added
  • Description modified (diff)

I can reproduce issue 1 on an iPad where the same delay seen on the iPhone becomes more noticeable.

#14 @iandstewart
7 years ago

  • Cc Frank Klein removed

#15 @iandstewart
7 years ago

  • Description modified (diff)

#16 @lancewillett
7 years ago

  • Description modified (diff)

#17 follow-up: @rachelbaker
7 years ago

I looked into the mobile swiping issue on iOS with the Featured Content Slider but wasn't able to completely remove the delay. I did notice that the delay time reduces as you continue swiping through the individual slides.

Also found a related issue, with swiping backward on iOS:

  1. Swipe from the first slide to the last slide.
  2. You will see a flash of all the slides before settling on the last slide.
  3. Now swipe backward again.
  4. You will notice the same flash of all the slides before settling on the second to last slide.
  5. Swipe backward again.
  6. You will experience the expected behavior of just viewing the previous slide, without the flash of all images.

#18 in reply to: ↑ 17 @lancewillett
7 years ago

Replying to rachelbaker:

I looked into the mobile swiping issue on iOS with the Featured Content Slider but wasn't able to completely remove the delay. I did notice that the delay time reduces as you continue swiping through the individual slides.

After more testing and debugging, I think is isn't something we can "fix" because the swipe event is so dependent on the actual movement of the finger. So you start to move it, and it'll jerk over because you're dragging it. :)

I think we'll need to wontfix it.

Also found a related issue, with swiping backward on iOS:

Thanks for finding that. I'll look.

#19 @lancewillett
7 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 26665:

Twenty Fourteen: fix two usability issues with touch events on mobile devices with the Featured Content slider:

  • Try to avoid the slight delay when swiping from one slide to the next.
  • Fix bug where second to last slide was animating like it was the last.

Fixes #26191.

#20 @lancewillett
7 years ago

In 26666:

Twenty Fourteen: remove unused variable in slider.js, see #26191.

Note: See TracTickets for help on using tickets.