WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#26215 closed enhancement (duplicate)

wp_is_mobile: maybe differentiate between tablets and phones

Reported by: iandstewart Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: General Keywords:
Focuses: Cc:

Description (last modified by iandstewart)

Maybe we should differentiate between tablets and phones. For example in Twenty Fourteen we hide content on phone-sized screens with display none which falsely suggests the content is not loaded -- and it probably shouldn't be. We can't use wp_is_mobile in it's current state to hide it because it doesn't differentiate between tablets and phones. Twenty Fourteen, for example, _does_ show content on tablets even though it doesn't on phones.

The attached patch is a proposal for allowing us to take care of that.

Attachments (1)

809559-wpismobile.diff (1.6 KB) - added by iandstewart 20 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 @iandstewart20 months ago

  • Description modified (diff)

comment:2 @dimadin20 months ago

wp_is_mobile() shouldn't be used on frontend since it doesn't work when page caching is used. I opened #26221 to address this issue.

comment:3 @johnbillion20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24541.

comment:4 @SergeyBiryukov20 months ago

  • Version changed from trunk to 3.7
Note: See TracTickets for help on using tickets.