WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#26226 closed defect (bug) (fixed)

THX "Add New Theme" copy has some overlapping issues at certain browser sizes

Reported by: jacklenox Owned by: iammattthomas
Milestone: 3.8 Priority: normal
Severity: normal Version: 3.8
Component: Customize Keywords: has-patch
Focuses: ui Cc:

Description

On the new theme page, the "Add New Theme" copy in the Add box sometimes overlaps the plus symbol within certain responsive breakpoints:

https://i.cloudup.com/I5j3PQmvBC.png

https://i.cloudup.com/jCuTOZRGbO.png

I'm including a simplistic patch which just shifts the text down by 30px to stop this happening at any breakpoint I have tested, but the symbol and text should probably be rolled into one element. If I get time I'll add a new patch that does this.

Attachments (2)

thx-alignment.patch (320 bytes) - added by jacklenox 8 years ago.
Screen Shot 2013-11-29 at Fri Nov 29 7.44.27 PM.png (278.9 KB) - added by designsimply 8 years ago.

Download all attachments as: .zip

Change History (11)

#1 @nacin
8 years ago

  • Component changed from Themes to Appearance
  • Milestone changed from Awaiting Review to 3.8

#3 @shaunandrews
8 years ago

  • Cc shaun@… added

#4 @SergeyBiryukov
8 years ago

  • Component changed from Appearance to Themes
  • Keywords ui-focus has-patch added

#5 @SergeyBiryukov
8 years ago

  • Component changed from Themes to Appearance

#6 @shaunandrews
8 years ago

Looks like its already been fixed in r26422.

#7 @jacklenox
8 years ago

Mmm, designsimply and I were just discussing this literally right now. It looks as though MT spotted it and changed it in the same way as suggested above. It's still not ideal so we'll suggest a further patch where the symbol and text are rolled into one element.

Last edited 8 years ago by jacklenox (previous) (diff)

#8 @designsimply
8 years ago

Just for reference, here's how it looks right now at 236px in Firefox 25.0.1 on Mac OS X 10.8.5:


#9 @iammattthomas
8 years ago

  • Owner set to iammattthomas
  • Resolution set to fixed
  • Status changed from new to closed

In 26584:

Ensure that 'Add New Theme' text doesn't overlap the + icon even at Firefox's ridiculously small 230px wide browser. Fixes #26226.

Note: See TracTickets for help on using tickets.