Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#26229 closed defect (bug) (duplicate)

3.8's What's New CSS bleeding into bbPress's What's New page

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: high
Severity: normal Version:
Component: Help/About Keywords: needs-patch
Focuses: Cc:

Description

The before/after CSS for the What's New page was previously only responsible for layout, and now adds icons to a few of the individual blocks.

Both bbPress and BuddyPress (and I think Easy Digital Downloads) mimic the look of WordPress's What's New page with their own, and rely on this CSS to provide the layout.

In current trunk, bbPress's What's New page has icons that are meant to represent WordPress's features that are in those positions.

Screenshot attached.

Attachments (1)

Screenshot 2013-11-24 23.50.43.png (98.3 KB) - added by johnjamesjacoby 8 years ago.

Download all attachments as: .zip

Change History (12)

#1 @iammattthomas
8 years ago

  • Cc mt@… added

#2 @helen
8 years ago

Two things - one, this CSS is bound to change, because we'll be updating the about page, and two, that we definitely should use a class specific to the icon in use so it doesn't bleed over like you are experiencing. Keeping this in 3.8 so we don't forget to do this when we tackle the about page.

#3 @Joen
8 years ago

  • Cc asmussen@… added

#4 @samuelsidler
8 years ago

  • Priority changed from normal to high

#5 @nacin
8 years ago

  • Component changed from Administration to Help/About

#6 @chriscct7
8 years ago

Yeah Easy Digital Downloads & a few of it's larger extensions use this. WooCommerce also at one point opened a Github ticket on their repo to add EDD's functionality to Woo. Not sure what happened with that since Github is down at the moment.

-Chris

#7 @chriscct7
8 years ago

  • Cc chriscct7@… added

#8 @mordauk
8 years ago

  • Cc pippin@… added

#9 @mordauk
8 years ago

Easy Digital Downloads does use the same about page structure, though we don't use the icons so we are unaffected by this (at least currently).

#10 @nacin
8 years ago

#26229 was marked as a duplicate.

#11 @nacin
8 years ago

  • Milestone 3.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26387.

Note: See TracTickets for help on using tickets.