WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2625 closed defect (bug) (fixed)

Posts with double-quote in title cause malformed XML

Reported by: thetorpedodog Owned by:
Milestone: Priority: normal
Severity: major Version: 2.0.2
Component: General Keywords: xml malformed comment template bg|has-patch bg|commit
Focuses: Cc:

Description

Steps to reproduce

  1. Set up your blog to send as application/xhtml+xml, for instance with WP Content Negotiator.
  1. Ensure that there is a comments_popup_link present on your homepage.
  1. Write a post featuring a "double quote" somewhere in the title.
  1. Go to your blog homepage.
  1. In Mozilla/Firefox: Yellow Screen of Death, whatever happens happens in Opera

Fix

line 315, wp-includes/comment-functions.php

CHANGE:

		echo ' title="' . sprintf( __('Comment on %s'), $post->post_title ) .'">';

TO:

		echo ' title="' . apply_filters('the_title',sprintf( __('Comment on %s'), $post->post_title )) .'">';

Attachments (3)

2625.diff (554 bytes) - added by davidhouse 8 years ago.
escape_title.diff (592 bytes) - added by markjaquith 8 years ago.
patch for /branches/2.0/
TRUNK_escape_title.diff (544 bytes) - added by markjaquith 8 years ago.

Download all attachments as: .zip

Change History (11)

davidhouse8 years ago

comment:1 davidhouse8 years ago

  • Keywords bg|has-patch bg|needs-testing added

Try that patch.

comment:2 thetorpedodog8 years ago

  • Keywords bg|works added; bg|needs-testing removed

Works for me.

comment:3 davidhouse8 years ago

  • Keywords bg|commit added; bg|works removed

markjaquith8 years ago

patch for /branches/2.0/

comment:4 ryan8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3873]) Specialchars title. Props David House and Mark Jaquith. fixes #2625

comment:5 ryan8 years ago

  • Resolution set to fixed

(In [3874]) Specialchars title. Props David House and Mark Jaquith. fixes #2625

comment:6 haxxor8 years ago

  • Version changed from 2.0.2 to 2.0.3

Just notifying: this bug has not been fixed in 2.0.3.

comment:7 haxxor8 years ago

  • Version changed from 2.0.3 to 2.0.2

Oops, didn't mean to change version.

comment:8 ryan8 years ago

It should be fixed in the 2.0.4 beta. Are you testing with the 2.0.4 beta?

Note: See TracTickets for help on using tickets.