WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#26259 closed defect (bug) (fixed)

New admin styling: Checkbox alignment in Menus page for menu location is off when multiple possible locations are present

Reported by: Hanni Owned by: iammattthomas
Milestone: 3.8 Priority: normal
Severity: minor Version: 3.8
Component: Administration Keywords: needs-patch
Focuses: ui Cc:

Description (last modified by SergeyBiryukov)

When creating a menu on nav-menus.php in trunk, and the theme has multiple possible locations (such as is the case with Twenty Fourteen), the alignment of the second location checkbox falls below the section title (in this case "theme locations"), and is out of line with the previous checkbox thus not only looking untidy but introducing a level of confusion (see attached screenshot).

I had a look around and it seems that in [24566] @markjaquith pushed the checkboxes onto their own line below the section title to accommodate longer strings in non-English languages. Apparently the new admin CSS doesn't have the same issue (I played around with longer strings and couldn't reproduce the overlap issue, but I could be wrong) and so the checkboxes are no longer on their own line as was the case in 3.6, and 3.7. This is wonderful, but does therefore introduce this quirk (I think).

Attachments (3)

Screen Shot 2013-11-26 at 10.31.26.png (39.4 KB) - added by Hanni 6 years ago.
Checkbox misalignment in trunk
Screen Shot 2013-11-26 at 10.36.20.png (39.5 KB) - added by Hanni 6 years ago.
Problem not present in 3.7
26259.diff (891 bytes) - added by mattheu 6 years ago.

Download all attachments as: .zip

Change History (7)

@Hanni
6 years ago

Checkbox misalignment in trunk

@Hanni
6 years ago

Problem not present in 3.7

#1 @ocean90
6 years ago

  • Keywords ui-focus added
  • Milestone changed from Awaiting Review to 3.8

@mattheu
6 years ago

#2 @mattheu
6 years ago

Taken a slightly different approach to the implementation, but it seems a bit more robust.

Also improved the appearance on smaller screens.

#3 @iammattthomas
6 years ago

  • Owner set to iammattthomas
  • Resolution set to fixed
  • Status changed from new to closed

In 26438:

Fix the alignment of checkboxes in menu location settings, and add responsive adjustments for those checkboxes. Fixes #26259, props mattheu.

#4 @SergeyBiryukov
6 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.