WordPress.org

Make WordPress Core

Opened 20 months ago

Last modified 17 months ago

#26267 new enhancement

Do action before #minor-publishing-actions in publish meta-box

Reported by: jonathanbardo Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Editor Keywords: 2nd-opinion
Focuses: Cc:

Description

I've stumble on a use case where we would have to create a custom preview button on the publish meta-box.

There is currently no hook to add custom content at the end of the #minor-publishing-actions div.

I propose adding a hook right before the division is closed.

Attachments (2)

26267.diff (447 bytes) - added by jonathanbardo 20 months ago.
26267.2.diff (471 bytes) - added by jonathanbardo 17 months ago.
Change name of action

Download all attachments as: .zip

Change History (9)

@jonathanbardo20 months ago

comment:1 @helen17 months ago

  • Keywords 2nd-opinion added

Adding a hook here is making me nervous for some reason, even though I usually love hooks on the edit screen. The publish metabox is already so cluttered and maintaining compat with hooks can make rethinking difficult. Would like some more opinions here.

comment:2 @mordauk17 months ago

I would prefer having the option that might result in a little clutter due to plugins than to not have the option.

comment:3 follow-up: @helen17 months ago

I think I'm more worried about maintaining compat into the future :)

comment:4 in reply to: ↑ 3 @mordauk17 months ago

Replying to helen:

I think I'm more worried about maintaining compat into the future :)

Maybe I'm just being daft but I'm having trouble thinking of compatibility issues this might raise in the future. Could you give me an example?

comment:5 @jonathanbardo17 months ago

I'm also having problem with foreseeing compatibilities issues. Right now the only way we can add a custom button to the publish meta-box is at the end. Having a hook here would make it more flexible.

comment:6 @SergeyBiryukov17 months ago

  • Component changed from General to Editor

comment:7 @SergeyBiryukov17 months ago

Related: #25279, #12567.

If we add a hook in there, it should probably be named post_submitbox_minor_actions for consistency with post_submitbox_misc_actions added in [12000], and go above <div class="clear"></div>.

@jonathanbardo17 months ago

Change name of action

Note: See TracTickets for help on using tickets.