Make WordPress Core

Opened 2 years ago

Closed 3 months ago

#26283 closed defect (bug) (wontfix)

Admin notice, update core-bug

Reported by: robsat91 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:


I am running on WP 3.7.1, but in wp-admin there is an admin-notice and i am being told to update to 3.7.1.
The wp version-check seems to be buggy. I have tracked the error down to "wp-includes/version.php".

The problem appears when i use an english installation of wordpress with norwegian language added afterwards.
In the norwegian installation of "wp-includes/version.php" the variable "$wp_local_package" is set (to "nb_NO"). But the variable is not set at all in the english installation. So when i add norwegian language (add lang-files, change define WPLANG in wp-config.php) to my english version (fetched from svn-tag) the admin notice appear.

When i add my quickfix in my theme (functions.php) it works great and the notice disappears:
$wp_local_package = WPLANG;

Change History (3)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Upgrade/Install

#2 @ocean90
22 months ago

  • Keywords reporter-feedback added; needs-patch removed

Hello robsat91, thanks for the report.

While you had this issue did you took a look at wp-admin/update-core.php? It seems like the English package was installed because the localized package wasn't ready at this time. So at wp-admin/update-core.php you can either update again or just hide the update.

Related: #27164

#3 @chriscct7
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

No reporter feedback in 2 years. Probably not a bug as mentioned in comment:2. Closing as wontfix. Feel free to reopen if you can provide steps to easily reproduce.

Note: See TracTickets for help on using tickets.