WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 7 weeks ago

#26302 closed enhancement (wontfix)

Specify display priority for list table columns

Reported by: helen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: ui Cc:

Description

Responsive list tables hide certain columns via CSS. This is great, but it's essentially hardcoded into the admin CSS and, in some instances, we are not able to target specifically enough to not cause unintended hiding elsewhere.

I propose a display priority concept - a column can be indicated as "high", "normal", or "low" priority (or similar), and breakpoints can progressively hide columns based on that priority. Core can be opinionated by default, but given the proliferation of custom post types and taxonomies, as well as the reuse of WP_List_Table, a developer API could be quite nice here.

Example of the concept: http://filamentgroup.com/lab/responsive_design_approach_for_complex_multicolumn_data_tables/

Previously: #26298 (bug caused by column names being the same between different object types but not of the same importance), #18198:77 (an experimental approach). Related: #25408 (indicating a primary column).

Change History (5)

comment:1 @DrewAPicture20 months ago

  • Cc xoodrew@… added

comment:2 @jdgrimes20 months ago

  • Cc jdg@… added

comment:3 @netweb20 months ago

  • Cc stephen@… added

comment:5 @helen7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Going to close in favor of #32395 - 19 months of reflection has told me that truncation as a responsive strategy is pretty terrible and there's no reason to encourage it.

Note: See TracTickets for help on using tickets.