Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 15 months ago

#26342 closed defect (bug) (maybelater)

Admin Color Scheme taken into account before being saved

Reported by: alphagolf_fr's profile AlphaGolf_fr Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords:
Focuses: ui Cc:

Description

At the user profile page, the choice for a color scheme is implicitely saved once previewed by the user, meaning, the change is taken into account even though the user leaves the page without saving from the 'Update Profile' button.

Is this on purpose and if so, why would it be different from all the other settings that actually need to be saved to avoid being discarded.

Change History (6)

#1 @SergeyBiryukov
11 years ago

  • Component changed from Users to Administration
  • Keywords ui-focus added

#2 follow-ups: @helen
11 years ago

  • Milestone changed from Awaiting Review to 3.8

It is by design, yes. The reasoning was that the live preview of the theme is unexpectedly lost when you navigate away.

For the record, I am and have been opposed to the auto-saving behavior here, because no other fields do it. I would very much rather see an indicator that you are previewing and/or an explicit preview button.

#3 in reply to: ↑ 2 @nacin
11 years ago

Replying to helen:

It is by design, yes. The reasoning was that the live preview of the theme is unexpectedly lost when you navigate away.

For the record, I am and have been opposed to the auto-saving behavior here, because no other fields do it. I would very much rather see an indicator that you are previewing and/or an explicit preview button.

I think we could probably just cause the preview to be lost when you navigate away. If this was in Screen Options or something (not saying it belongs there), auto-saving makes sense. On the profile form with a save button, it does not. I don't think the "unexpectedly" is actually unexpected. Could be worth a user test on asking a user to change their color scheme.

#4 @nacin
11 years ago

  • Milestone 3.8 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Some further discussion and thought on this (also: IRC) makes me think that the current situation is the best possible user experience.

#5 @sabernhardt
15 months ago

#57954 was marked as a duplicate.

#6 in reply to: ↑ 2 @sabernhardt
15 months ago

  • Resolution changed from wontfix to maybelater

I would very much rather see an indicator that you are previewing and/or an explicit preview button.

@dhrumilk also questioned why the color scheme setting behaves differently than other settings on the profile screen, and I have been surprised by the automatic save without clicking Update Profile, too. This has no indication that the colors will stay that way when you leave the page.

If the color scheme changes when clicking a Preview button instead of when selecting a radio button, showing a second button to keep/restore your previous selection would at least imply that the setting is saved. I expect there is a better option than that, too.

I'm not eager to reopen without a clear direction, but I do not agree with calling the current behavior the "best possible" user experience.

Note: See TracTickets for help on using tickets.