WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#26371 closed defect (bug) (duplicate)

Duplicate tags

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6.1
Component: Taxonomy Keywords:
Focuses: Cc:
PR Number:

Description

Wordpress is generating duplicate tags when using the autocomplete to assign tags. Even though there is already a tag in database of the tag title and this was selected from the autocomplete, wordpress still generates a new tag. I believe this is happening because the text of the tag has an ampersand symbol in it.

So here is how to replicate the error.

  1. Create a tag in a post with an ampersand in the body of the tag. E.g A&A
  2. In tag editor change the slug of this tag to something different. E.g BB
  3. Create another post and in the tag box, type in the name of you tag.
  4. Select tag from autocomplete menu.
  5. Publish post
  6. Go to tag editor. Search for tag.
  7. You will see listed two, exactly the same tags but with different slugs. E.g A&A -> aa, A&A -> bb.

I have replicated this bug a number of times. I do not believe it any of the plugins I am using are doing this.

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17689.

Note: See TracTickets for help on using tickets.