WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#26382 closed defect (bug) (duplicate)

Scaling Image Up Fails Silently

Reported by: bandonrandon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

The ability to scale images up was removed (I think in 3.5) and the text was changed in r24562 per this ticket #323713.

However, when using the Image editor to scale an image if you enter a value larger than the image we still attempt to re-size the image and the "Restore Original link appears"

To Reproduce

1) Select an image from the media library and click the "Edit Image" button
https://i.cloudup.com/FI6vrPykAw-3000x3000.png

2) Enter dimensions larger than the original dimensions. You will see a red "!" as a warning but ignore this and click the "Scale" button
https://i.cloudup.com/00DyBO7Rb5-3000x3000.png

3) The site will try to re-size the image and gives a success message.
https://i.cloudup.com/VLRLKcN8N5-3000x3000.png

The only problem is that no new image was created. To fix this we either need to give a warning and not produce a "Restore Original Image" link or prevent the user from clicking the link at all.

My vote is since we already have JavaScript that detects when the image is too large the simplest solution would be to disable the "Scale" button when the warning "!" shows.

Change History (2)

#1 @bandonrandon
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26381.

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Version changed from trunk to 3.5
Note: See TracTickets for help on using tickets.