Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 3 years ago

#26421 closed defect (bug) (fixed)

DFW has a border around the editor

Reported by: nacin's profile nacin Owned by: nacin's profile nacin
Milestone: 3.8 Priority: normal
Severity: major Version: 3.8
Component: Editor Keywords: has-patch
Focuses: Cc:

Description

In 3.8 (not reproducible in 3.7), the editor has an odd glow border. Can't place where it is coming from. Screenshot attached.

Given how distracting this is, I'd say this is pretty major. :-)

Attachments (4)

Screen Shot 2013-12-04 at 6.45.01 PM.png (17.3 KB) - added by nacin 11 years ago.
26421.diff (713 bytes) - added by jeremyfelt 11 years ago.
Screen Shot 2013-12-04 at 8.30.54 PM.png (28.1 KB) - added by nacin 11 years ago.
Without the shadow.
Screen Shot 2013-12-04 at 8.31.09 PM.png (23.3 KB) - added by nacin 11 years ago.
With the shadow. Feels heavier, something I've always hated about our visual editor.

Download all attachments as: .zip

Change History (13)

#1 @nacin
11 years ago

This is with Twenty Ten, FWIW. Don't know if that makes a difference, but doubtful.

DFW = distraction-free writing, the fullscreen mode.

#2 @jeremyfelt
11 years ago

Same thing in Twenty Fourteen, confirmed in Chrome and Firefox

@jeremyfelt
11 years ago

#4 @jeremyfelt
11 years ago

26421.diff removes the box shadow added to html in [26072].

#5 @jeremyfelt
11 years ago

  • Keywords has-patch added

@nacin
11 years ago

Without the shadow.

@nacin
11 years ago

With the shadow. Feels heavier, something I've always hated about our visual editor.

#6 @nacin
11 years ago

This is used on the main editor page. That said, I think the editing experience is improved significantly with it removed.

Since it is applied to the html element rather than overlaid on the editor, it gets lost when you scroll down. So maybe it's an indication that you're at the top of the document. I dunno. I am fine with ditching it, but will leave it to MT and melchoyce for that decision. If there is a desire to keep it, I am sure someone (azaozz if necessary) can work out the right CSS to not have it apply in DFW.

#7 @melchoyce
11 years ago

I think the regular editor feels fine without the shadow. Let's ditch it.

#8 @nacin
11 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 26659:

Remove the shadow on the TinyMCE editor.

This removes it from distraction-free writing and also gives the editor a bit of a lighter feel.

fixes #26421.

This ticket was mentioned in Slack in #core-editor by itsjusteileen. View the logs.


3 years ago

Note: See TracTickets for help on using tickets.