Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26439 closed defect (bug) (fixed)

Arrows for revisions slider handle in two handled mode need attention

Reported by: adamsilverstein's profile adamsilverstein Owned by: iammattthomas's profile iammattthomas
Milestone: 3.8 Priority: low
Severity: minor Version: 3.8
Component: Revisions Keywords:
Focuses: Cc:

Description

When viewing the revisions screen in 'compare two revisions' mode, the new graphics for the right hand slider handle introduced by 3.8/mp6 are slightly off (they are also slightly different in firefox vs chrome):

http://f.cl.ly/items/2R1z2L3w22182i3E2f14/Revisions%20%E2%80%B9%20WordPress%20Development%20Test%20Environment%20%E2%80%94%20WordPress%202013-12-05%2009-22-08.jpg

by comparison, the handles in 3.6 looked like this:
http://f.cl.ly/items/2F2b0M3C2x0K141j0k0i/Revisions%20%E2%80%B9%20WordPress%20Development%20Test%20Environment%20%E2%80%94%20WordPress%202013-12-05%2008-39-26.jpg

a small tweak to the css for the right handle gets us this, which is better (patch attached)
http://f.cl.ly/items/2B1o3F0V2Z2x1O3q3c2I/Revisions%20%E2%80%B9%20WordPress%20Development%20Test%20Environment%20%E2%80%94%20WordPress%202013-12-05%2009-45-06.jpg

Another more serious regression is the handles in RTL mode - the placement is off (should be over tick mark) and the arrow directions are reversed - whoops! Fixing this one next:
http://f.cl.ly/items/2j1s290Z1715450V2v3i/%D7%92%D7%A8%D7%A1%D7%90%D7%95%D7%AA%20%E2%80%BA%20WordPress%20Development%20Test%20Environment%20%E2%80%94%20%D7%95%D7%95%D7%A8%D7%93%D7%A4%D7%A8%D7%A1%202013-12-05%2009-57-10.jpg

Attachments (2)

26439.diff (350 bytes) - added by adamsilverstein 10 years ago.
correct arrow placement for two handles mode to handle
26439.2.diff (904 bytes) - added by adamsilverstein 10 years ago.
correct placement & direction of slider handles in rtl mode

Download all attachments as: .zip

Change History (9)

@adamsilverstein
10 years ago

correct arrow placement for two handles mode to handle

#1 @matt
10 years ago

  • Milestone changed from Awaiting Review to 3.8
  • Priority changed from normal to low
  • Severity changed from normal to minor

#2 @iammattthomas
10 years ago

  • Owner set to iammattthomas
  • Status changed from new to assigned

#3 @iammattthomas
10 years ago

In 26709:

Fix the positioning of arrow icons in the slider buttons in Revisions. See #26439.

#4 @iammattthomas
10 years ago

I went about this a slightly different way because there was some crufty/unnecessary CSS on those icons. Fixing the RTL issue is still outstanding.

@adamsilverstein
10 years ago

correct placement & direction of slider handles in rtl mode

#5 @adamsilverstein
10 years ago

26439.2.diff​: correct placement & direction of slider handles in rtl mode:

http://f.cl.ly/items/3X1h270g082j2o1T012t/%D7%92%D7%A8%D7%A1%D7%90%D7%95%D7%AA%20%E2%80%BA%20WordPress%20Development%20Test%20Environment%20%E2%80%94%20%D7%95%D7%95%D7%A8%D7%93%D7%A4%D7%A8%D7%A1%202013-12-05%2020-52-32.jpg

#6 @iammattthomas
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 26717:

Correct the direction of arrow icons when comparing revisions in RTL. Fixes #26439, props adamsilverstein.

#7 @iammattthomas
10 years ago

r26717 fixes the display bug for RTL, but it's working around the incorrectly generated RTL css. Barring a solution for that before freeze though, this fixes the immediate problem.

Note: See TracTickets for help on using tickets.