WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#26456 closed defect (bug) (fixed)

New admin styling: Disabled select boxes are not distinguishable

Reported by: TobiasBg Owned by: iammattthomas
Milestone: 3.8 Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords: has-patch
Focuses: ui Cc:

Description

Similarly to #26004 (which deals with checkboxes and radio buttons), disabled HTML <select disabled> boxes can not be distinguished from non-disabled ones.

There is CSS for select[disabled] in wp-admin.css to give it a lighter color, but that's again overridden by a more specific selector .wp-admin select.

Caused by [26293].

There's also a duplicate color property set for select. The attached patch fixes this.

Attachments (1)

26456.patch (438 bytes) - added by TobiasBg 5 years ago.
Fix color of disabled select boxes

Download all attachments as: .zip

Change History (4)

@TobiasBg
5 years ago

Fix color of disabled select boxes

#1 @TobiasBg
5 years ago

  • Keywords has-patch ui-focus added

#2 @nacin
5 years ago

  • Milestone changed from Awaiting Review to 3.8
  • Owner set to iammattthomas
  • Status changed from new to assigned

#3 @iammattthomas
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 26733:

Ensure that disabled select elements are distinguishable from normal ones. Fixes #26456, props TobiasBg.

Note: See TracTickets for help on using tickets.