WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#26458 closed defect (bug) (fixed)

New admin styling: Admin menu broken between 783px and 797px browser widths

Reported by: johnbillion Owned by: azaozz
Milestone: 3.8 Priority: low
Severity: major Version: 3.8
Component: Administration Keywords: 2nd-opinion dev-feedback
Focuses: Cc:
PR Number:

Description (last modified by nacin)

This seems to be limited to Chrome on Windows. Cannot reproduce in Firefox or IE on Windows, nor in any browser on OS X. Not tested on Linux.

Steps to reproduce:

  • Open up Chrome on Windows (I'm using Chrome 31 and 33 on Win7)
  • Resize your browser window to between 783px and 797px
  • Visit the WordPress admin area and try to use the admin menu
  • Note that the admin menu flyouts don't appear and menu items aren't clickable

Resizing the window down from a wider width doesn't trigger the problem without a reload. It needs to be a fresh page load at the narrower width.

The original reporter, christer88, can reproduce the problem down to 768px width, which is weird because the narrower media query isn't kicking in. I'm unable to reproduce though.

Change History (9)

#1 @nacin
6 years ago

  • Component changed from Appearance to Administration

"Appearance" refers to the Appearance screens (Themes, Header, Background, Customizer, etc). Yeah, it's confusing.

Last edited 6 years ago by nacin (previous) (diff)

#2 @nacin
6 years ago

  • Description modified (diff)

#3 @nacin
6 years ago

  • Description modified (diff)

#4 @christer88
6 years ago

Bug produced at 770px window size in Google Chrome 32.0.1700.39 beta-m Aura, Windows 7: http://i.imgur.com/Uizl1zz.png

Last edited 6 years ago by christer88 (previous) (diff)

#5 @azaozz
6 years ago

Confirmed in Chrome/Win7. Happens between 783px and 799px window width. There is inconsistency in calculating the window width from JS when there is a vertical scrollbar. Patch coming up.

Last edited 6 years ago by azaozz (previous) (diff)

#6 @nacin
6 years ago

  • Owner set to azaozz
  • Status changed from new to assigned

#7 @azaozz
6 years ago

In 26743:

Responsive menu: fix calculation of the responsive trigger width from JS. It is affected by a vertical scrollbar width in some browsers. See #26458.

#8 @azaozz
6 years ago

Leaving the ticket open as this fix needs some quick testing in as many mobile devices as possible (don't forget to clear cache before testing).

#9 @azaozz
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 26785:

Fake a "non-responsive" window width for IE < 9 when folding/unfolding the menu (old IE doesn't support @media), fixes #26458.

Note: See TracTickets for help on using tickets.