WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#26460 closed defect (bug) (duplicate)

Featured image not showing when using SVG

Reported by: Swellfire Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Media Keywords:
Focuses: Cc:

Description

After enabling SVG

function cc_mime_types( $mimes ){
	$mimes['svg'] = 'image/svg+xml';
	return $mimes;
}

add_filter( 'upload_mimes', 'cc_mime_types' );

and setting a featured image to a SVG, the image does not show up in the backend. Worked in 3.6

Change History (4)

#1 @markoheijnen
4 years ago

I'm curious how this could have worked for 3.6 since it will not get the height/width of an image. And this is something really important. If it did worked in 3.6 then I tend to say it was a bug in 3.6.

Edit: I will look into it and see it I can reproduce this in 3.6

Last edited 4 years ago by markoheijnen (previous) (diff)

#2 @nacin
4 years ago

  • Component changed from General to Media

Thanks for the report, Swellfire.

#3 @arippberger
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26256.

#4 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.