Make WordPress Core

#26464 closed enhancement (duplicate)

Clicking a link in the customizer controls doesn't change URL in the browser location bar

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.4
Component: Customize Keywords:
Focuses: Cc:


To reproduce:

  • Open the theme customizer for Twenty Fourteen
  • Expand the 'Featured Content' control and click one of the links therein
  • Note that the browser navigates to the URL but the location bar remains at customize.php.

Change History (2)

#1 @ocean90
18 months ago

  • Keywords reporter-feedback added

Which browser?

Couldn't reproduce in Chrome 34, Firefox 29 and IE 9.

#2 @westonruter
16 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from defect (bug) to enhancement
  • Version set to 3.4

I didn't see this issue when I reported #28536, “add browser history and deep linking for navigation in Customizer preview”. This will result in the URL being updated (via HTML5 history.pushState) when navigating within the Customizer preview. This ticket has a working patch.

Note: See TracTickets for help on using tickets.