WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 weeks ago

#26482 closed defect (bug) (fixed)

Flyout submenus can be hidden on mobile devices

Reported by: miqrogroove Owned by: nacin
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords: has-patch commit
Focuses: ui Cc:

Description

Steps to reproduce:

  1. Navigate to one of the pages in the Appearance menu.
  2. Try to open the Settings menu.

Expected result: Settings menu should open.

Actual result: Only the top 4 menu items are visible.

Attachments (4)

IMG_0740_2013_12_08_01h51m26s.PNG (211.8 KB) - added by miqrogroove 4 months ago.
iPad Landscape Screen Shot
IMG_0741_2013_12_08_01h51m45s.PNG (200.5 KB) - added by miqrogroove 4 months ago.
iPad Portrait Screen Shot
26482.patch (2.2 KB) - added by ocean90 8 weeks ago.
ie11-surface.png (501.8 KB) - added by iammattthomas 4 weeks ago.

Download all attachments as: .zip

Change History (13)

miqrogroove4 months ago

iPad Landscape Screen Shot

miqrogroove4 months ago

iPad Portrait Screen Shot

comment:1 miqrogroove4 months ago

Also found: No problem in landscape rotation if the "Collapse menu" link is tapped prior to Settings.

comment:2 SergeyBiryukov4 months ago

  • Component changed from Menus to Administration
  • Keywords ui-focus added

comment:3 ocean908 weeks ago

  • Keywords needs-patch added
  • Summary changed from RC1 Settings Menu Doesn't Work on iPad to Flyout menus can be hidden on an iPad

Could reproduce this in current trunk and iOS simulator.

ocean908 weeks ago

comment:4 ocean908 weeks ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.9
  • Summary changed from Flyout menus can be hidden on an iPad to Flyout submenus can be hidden on mobile devices

26482.patch uses the same code as it's used in the hoverIntent callback.

comment:5 iammattthomas4 weeks ago

26482.patch looks good to me; it fixes the issue on iPad and a Nexus 10 tablet. On a Surface running Windows 8.1/IE 11 the submenu still drops below the bottom of the viewport.

iammattthomas4 weeks ago

comment:6 samuelsidler3 weeks ago

Since we're running out of time for 3.9, can we land 26482.patch and punt this ticket to 4.0-early to fix the issue on Surface? iOS is way more used than Surface and getting that patch in will make things better for them and not worse for anyone else.

comment:7 samuelsidler3 weeks ago

  • Keywords commit added

comment:8 samuelsidler3 weeks ago

The issue in comment 5 (broken on Surface) has been spun out into #27543.

comment:9 nacin3 weeks ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 27775:

Fix flyout menus on most mobile devices.

props ocean90.
fixes #26482.

Note: See TracTickets for help on using tickets.