WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#26488 closed defect (bug) (worksforme)

Ugly Font Smoothing in Firefox Menus

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords:
Focuses: ui Cc:

Description

When I hover the fly-out menu links in Firefox, the text of the whole menu becomes less bold and appears highly ClearType'd.

The admin bar, and the non-fly-out items do not seem to be affected.

Attachments (2)

before.png (47.6 KB) - added by miqrogroove 7 years ago.
after.png (36.3 KB) - added by miqrogroove 7 years ago.

Download all attachments as: .zip

Change History (16)

@miqrogroove
7 years ago

@miqrogroove
7 years ago

#1 @SergeyBiryukov
7 years ago

  • Component changed from Menus to Administration
  • Keywords ui-focus added

Confirmed.

#2 @iammattthomas
7 years ago

Confirmed, I see this when hovering over adminmenu items in Firefox 25 on Windows XP. It appears to be confined to Firefox, the cause is unknown to me.

#3 @miqrogroove
7 years ago

#26654 was marked as a duplicate.

#4 @miqrogroove
7 years ago

  • Summary changed from RC1 Ugly Font Smoothing in Firefox Menus to Ugly Font Smoothing in Firefox Menus

#5 @mjbanks
7 years ago

The CSS is set to call -webkit-font-smoothing: subpixel-antialiased; in wp-admin.css, and it also has -moz-osx-font-smoothing: grayscale; for a many elements, but Firefox doesn't fully support CSS font smoothing, even with the vendor prefix, per MDN: https://developer.mozilla.org/en-US/docs/Web/CSS/font-smooth

There seems to be a lot of issues with Open Sans and Firefox related to font smoothing. I'm not sure it can totally be fixed unless Mozilla adds CSS font-smoothing (or it gets adapted as a CSS standard)?

#6 @iseulde
7 years ago

  • Keywords close added

Can't reproduce this in trunk nor 3.8.1.

#7 @iseulde
7 years ago

Tested with Firefox 27.0.1.

This ticket was mentioned in IRC in #wordpress-ui by helen. View the logs.


7 years ago

#9 @miqrogroove
7 years ago

  • Keywords close removed

Definitely still problems in 3.8.1.

#10 @miqrogroove
7 years ago

Noticing the same problem in the admin bar now too.

#11 @miqrogroove
7 years ago

Same problem in trunk, now 3.9-beta3-27851-src

#12 @chriscct7
5 years ago

  • Keywords needs-testing good-first-bug added

Verify this still exists first with Firefox

#13 @miqrogroove
5 years ago

Worksforme in 4.3.1, Firefox 40, Windows 10

#14 @chriscct7
5 years ago

  • Keywords needs-testing good-first-bug removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Worksforme. Firefox 41.0.2. Windows 7 and 8.1.

Version 0, edited 5 years ago by chriscct7 (next)
Note: See TracTickets for help on using tickets.