WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 days ago

Last modified 3 days ago

#26490 closed defect (bug) (wontfix)

3.8 Requires Font Smoothing?

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords:
Focuses: Cc:

Description

The upgrade to 3.8 will be an enormous regression for anyone not using font smoothing.

I've raised this concern in the past with front-end themes, but those can be changed easily. With this new admin interface, if there are people still blogging with the no-font-smoothing OS preference, they are going to think something has gone horribly wrong after upgrading WordPress.

Has any consideration been given to implementing some backwards compatibility so that fonts don't just look good on some computers but terrible on others?

Attachments (5)

firefox-xp.png (136.0 KB) - added by iammattthomas 4 months ago.
Firefox in Windows XP, no font smoothing
firefox.png (40.6 KB) - added by miqrogroove 4 months ago.
chrome.png (24.5 KB) - added by miqrogroove 4 months ago.
nope.png (14.0 KB) - added by iammattthomas 4 months ago.
wordpress37.png (53.2 KB) - added by miqrogroove 4 months ago.

Download all attachments as: .zip

Change History (22)

iammattthomas4 months ago

Firefox in Windows XP, no font smoothing

comment:1 iammattthomas4 months ago

I've been testing in Windows XP without font smoothing enabled since the early days of MP6; as far as I am aware readability is no worse than it was in 3.7.

comment:2 miqrogroove4 months ago

Wow, man it doesn't look anything like that on my XP machines. I'll grab some screenshots.

miqrogroove4 months ago

miqrogroove4 months ago

comment:3 follow-ups: miqrogroove4 months ago

Screen shots attached. iammattthomas, clearly you have some kind of font smoothing enabled that I do not.

comment:4 in reply to: ↑ 3 ; follow-up: nacin4 months ago

Replying to miqrogroove:

Screen shots attached. iammattthomas, clearly you have some kind of font smoothing enabled that I do not.

How. Can. You. Internet. Like. This.

iammattthomas4 months ago

comment:5 iammattthomas4 months ago

Yeah, no, no font smoothing here. Not sure what's going on there.

miqrogroove4 months ago

comment:6 in reply to: ↑ 4 miqrogroove4 months ago

Replying to nacin:

How. Can. You. Internet. Like. This.

I don't. I use WordPress 3.7. See new attachment.

comment:7 dd324 months ago

Looking at the screenshots here, it's shouting cleartype or some kind of font smoothing for iammattthomas, and none for miqrogroove (good example here: http://www.microsoft.com/typography/cleartype/tuner/step1.aspx )

IIRC, some windows XP graphics drivers included their own smoothing, and it was also different between LCD and CRT screens (and now VM's too).. even then, it's also going to depend on the font & screen resolution.

I'm not sure there's anything we'll be able to do for those who have no kind of font smoothing enabled though.

comment:8 dd324 months ago

Also, specific versions of browsers / OS platforms is required, Macs generally do font smoothing vastly differently.

Looking around, these screenshots could be caused by lower-resolution & -webkit-font-smoothing: antialiased being used (as this suggests)

comment:9 miqrogroove4 months ago

I'm on Windows 8 or iPad these days, but I read that 30% of web traffic still comes from XP clients. http://bit.ly/18htxfG

comment:10 follow-up: iammattthomas4 months ago

I believe that we're only using -webkit-font-smoothing: antialiased on icons, where we specifically don't want the added visual weight of subpixel antialiasing on our icons. Otherwise we either don't specify it or we specify subpixel-antialiasing specifically, for the readability reasons outlined in dd32's comment. (Though this is moot re: IE anyway)

Last edited 4 months ago by iammattthomas (previous) (diff)

comment:11 dd324 months ago

I believe that we're only using -webkit-font-smoothing: antialiased on icons

Ah yes, you're right, nevermind then, I had mis-remembered it's usage within core after seeing it used so much for icons :)

comment:12 in reply to: ↑ 10 ; follow-up: Joen4 months ago

  • Cc asmussen@… added

I don't know the exact details surrounding it, probably Dion is right that some graphics drivers render fonts differently. But I've seen this before, and it basically applies to nearly all webfonts. Here's a screenshot showing IE6:

https://cloudup.com/cOwp59R4gmf

That's the Google Chrome download page, which also uses Open Sans, running in my Chrome VM.

We might want to disable webfonts on systems without font smoothing enabled. Should be possible:

http://stackoverflow.com/questions/4328558/can-you-detect-if-cleartype-is-enabled-on-pc-via-javascript

comment:13 SergeyBiryukov4 months ago

I can reproduce firefox.png with font smoothing disabled.

comment:14 in reply to: ↑ 12 miqrogroove4 months ago

Replying to Joen:

Here's the how-to link for anyone that missed it: http://bit.ly/1aOftoV

comment:15 miqrogroove4 months ago

  • Summary changed from RC1 Requires Font Smoothing? to 3.8 Requires Font Smoothing?

comment:16 in reply to: ↑ 3 bflmpsvz3 days ago

Replying to miqrogroove:

Screen shots attached. iammattthomas, clearly you have some kind of font smoothing enabled that I do not.

Do not forget that Firefox ignores system settings regarding fonts. It looks like you have set
gfx.font_rendering.cleartype.use_for_downloadable_fonts FALSE in Firefox. Because WordPress sents antialiased fonts, Firefox with this setting make simply black-and-white font from that and then it looks like it looks.

I hate subpixel antialiasing and I hate WordPress, which use it (or webmasters use it?). I would like if the appearance was like on your 3.7 screenshot, but no way - everywhere that rainbow fonts which looks like image from bad cheap camera with huge chromatic aberration :-( .

comment:17 iammattthomas3 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

The issue described in this ticket is not specific to WordPress or the way WordPress implemented webfonts; it's simply a side effect of the way webfonts are rendered when a user has disabled font smoothing in their OS. I don't believe a fix for this is necessary given that it affects a substantial and growing proportion of websites and an insubstantial and shrinking proportion of users, but if anyone is interested in working on a solution, you may be interested in this article which describes a method of detecting the presence of font smoothing and falling back to a system font if it is disabled. http://wellcaffeinated.net/articles/2012/01/25/font-smoothing-detection-modernizr-style/

I think this ticket is safe to mark as wontfix and a new issue can be created if someone does decide to work on that fallback.

Last edited 3 days ago by iammattthomas (previous) (diff)
Note: See TracTickets for help on using tickets.