WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#2651 closed defect (bug) (duplicate)

404.php not implemented with different permalink structure

Reported by: sluggo Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.2
Component: Administration Keywords:
Focuses: Cc:

Description

When you switch the permalink structure from "Default" to one of the other choices, it stops catching 404 errors and serving 404.php--even if you go directly to index.php?error=404.

Change History (5)

comment:1 davidhouse8 years ago

Works on my system. Try disabling all plugins, switching to the default theme and trying again. If that still doesn't work, then can you install dump-env [1] and give us the output?

[1]: http://dev.wp-plugins.org/file/dump_env/trunk/dump_env.php

comment:2 Viper007Bond8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me as well.

Custom structure in use: http://www.viper007bond.com/archives/2006/04/02/weathericon-v3-beta/

404's working: http://www.viper007bond.com/foo/bar/

Reopen if it still doesn't work with all plugins disabled and such.

comment:3 sluggo8 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I changed to default theme, disabled all plugins, same problem. I installed the dump plugin and posted the results to http://www.unknown.nu/temp/dump.html.

comment:4 mikeleeorg8 years ago

I just posted a report on this bug to the forum, at:
http://wordpress.org/support/topic/68607

It includes steps to reproduce it as well. My dump_env feedback, which I created with all plugins deactivated and the default theme selected, is here:
http://mikelee.org/dump_env.html (view the source of page)

To see the 404 error I'm currently receiving, visit:
http://www.mikelee.org/404

Currently, the plugins I'm using are:

Please let me know if I can provide any more info. From what I've seen at the forum, there seem to be a number of users facing this bug. If there's any way I can persuade you to raise its priority, please let me know! Thanks!

comment:5 jhodgdon7 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Note: This user resolved his problem in the Support Forum:

My sysadmin looked into the problem, did some research, and discovered that FastCGI was causing the problem. The solution has already been documented here on this forum, in the thread http://wordpress.org/support/topic/67416

It appears that the solution is in #2628, which is marked fixed.

I'll close this as a duplicate of that bug, since it appears that is the fix.

Note: See TracTickets for help on using tickets.