WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#26512 closed defect (bug) (duplicate)

Custom Post Type Slug Conflicts With Page Slug

Reported by: pressuser79 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

  1. Create a page called "test. It will be visible at http://site.com/test
  2. Create a new Custom Post Type (CPT), say "Examples".
  3. Inside the editor for the CPT, add a new post. Give it a name of "test".

Ideally the CPT SHOULD be visible at http://site.com/examples/test, but Wordpress will prefer it to exist at a slug that does not conflict with the page slug - probably something like http://site.com/examples/test-2.

This constraint makes Wordpress almost unusable for some sites.

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Component changed from General to Post Types
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18962.

Note: See TracTickets for help on using tickets.