WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 14 months ago

Last modified 14 months ago

#26540 closed defect (bug) (fixed)

TinyMCE Paste thinks Firefox 20+ is old version of Firefox

Reported by: programmin Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 2.8
Component: TinyMCE Keywords: has-patch 3.9-early
Focuses: Cc:

Description

TinyMCE Paste plugin thinks the latest Firefox 26 is older firefox, and only adds a Ctrl+V cleanup handler, where onPaste works all the time.

This is caused by this line in wp includes itnymce/plugins/paste/editor_plugin_src.js:


// Is it's Opera or older FF use key handler
				if (tinymce.isOpera || /Firefox\/2/.test(navigator.userAgent)) {

... and since it thinks it's old Firefox, it only adds keyboard handler.

Because of this, Ctrl+V and right click paste are inconsistent. Ctrl+V doesn't clean up.

Attachments (1)

26540.patch (819 bytes) - added by jdgrimes 19 months ago.
Possible patch

Download all attachments as: .zip

Change History (7)

comment:1 @SergeyBiryukov19 months ago

  • Keywords needs-patch added

@jdgrimes19 months ago

Possible patch

comment:2 @jdgrimes19 months ago

  • Keywords has-patch needs-testing added; needs-patch removed
  • Version changed from trunk to 3.4

I've attached a patch with a possible fix. It looks like this dates back to [19945].

comment:3 @SergeyBiryukov19 months ago

  • Keywords 3.9-early added
  • Milestone changed from Awaiting Review to Future Release
  • Version changed from 3.4 to 2.8

Introduced in [11078].

comment:4 @programmin19 months ago

Firefox 2 is very old, maybe we can remove this check?

comment:5 @iseulde14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

This is fixed in TinyMCE 4.0.

comment:6 @ocean9014 months ago

  • Keywords needs-testing removed
  • Milestone changed from Future Release to 3.9
  • Resolution changed from invalid to fixed
Note: See TracTickets for help on using tickets.