Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26545 closed defect (bug) (invalid)

Jetpack 2.6 and 2.7 bug

Reported by: jimmyhazard's profile jimmyhazard Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Upgraded from Jetpack 2.5 to 2.6 and on my shopping cart page (http://themakeuplight.com/cart/) received the following error

Warning: preg_match() expects parameter 2 to be string, object given in /home/content/63/11739663/html/wp-includes/post-template.php on line 199

Catchable fatal error: Object of class WP_Post could not be converted to string in /home/content/63/11739663/html/wp-includes/post-template.php on line 217

Saw that there was a Jetpack 2.7 so I upgraded to that. Still received the error.

Searched the forums and found someone else having this problem on a totally different page (not shopping cart related at all) http://wordpress.org/support/topic/hyperlink-causes-error-in-posts?replies=12

So I deactivated Jetpack completely and the cart works.

Tried to reactivate Jetpack and received the error again. Both with linking Jetpack to my Wordpress.com account and not linking it.

From the varying circumstances in the other person and I receiving the same error it seems that Jetpack is the culprit.

Change History (2)

#1 @knutsp
10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Jetpack is a plugin and not part of core. Please report this to http://wordpress.org/plugins/jetpack/

#2 @SergeyBiryukov
10 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Version trunk deleted
Note: See TracTickets for help on using tickets.