WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#26567 closed defect (bug) (fixed)

z-index admin submenu issues

Reported by: dennis_f Owned by: nacin
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords: has-patch
Focuses: ui Cc:
PR Number:

Description

Previously: #26280

The issue doesn't exist in WP 3.7, as the #adminmenuwrap element doesn't have any specific z-index applied, I just inspected the code in 3.7 and I can see that the computed z-index of the #adminmenuwrap element is auto.

Right now the #adminmenuwrap has a z-index of 99 which overwrites the z-index of .wp-submenu of 9999 (as it is its parent), so the .wp-submenu element goes below elements that have z-index of 100 or greater.

As an example, as I mentioned in #26280, just use the browser developer tools to set a z-index of 100 to the Welcome Panel:

.welcome-panel{
	position:relative;
	z-index:100;
}

and you will see how it goes over the submenu:

http://img7.imageshack.us/img7/51/m980.png

In fact there are no visual problems with WordPress by itself, but that would limit the plugin/theme developers to use elements with z-index greater than 99 - any element that has at least a z-index of 100 will get displayed over the submenu element.

Attachments (1)

26576.patch (559 bytes) - added by mordauk 6 years ago.
Set .sticky-menu #adminmenuwrap to z-index of 999 to match .wp-submenu

Download all attachments as: .zip

Change History (14)

@mordauk
6 years ago

Set .sticky-menu #adminmenuwrap to z-index of 999 to match .wp-submenu

#1 @mordauk
6 years ago

  • Cc pippin@… added

#2 @MikeHansenMe
6 years ago

  • Keywords has-patch added

#3 @iammattthomas
6 years ago

I'd set this z-index to 9999 in r26442; nacin changed it to 99 in r26701, it looks like possibly because of a conflict with thickbox or the theme detail overlay. I haven't yet tried a z-index of 999 as in mordauk's patch, but it should be tested with thickbox and themes to make sure it causes no regressions.

#4 @nacin
6 years ago

  • Milestone changed from 3.8.1 to 3.8.2

Given the lack of movement/study/interest, this is going to need to wait for 3.8.2 at this point.

#5 @jeremyfelt
6 years ago

  • Focuses ui added

#6 follow-up: @mordauk
6 years ago

26576.patch works correctly with the theme details popup: http://d.pr/i/BOhG, though it overlaps Thickbox: http://d.pr/i/8E2H

I'm not sure the thickbox overlap is an issue, however, since it's not possible to show a submenu while thickbox is open, due to the overlay. I had to manually add the opensub class to the menu item in order to take the screenshot.

#7 in reply to: ↑ 6 @helen
6 years ago

Replying to mordauk:

I'm not sure the thickbox overlap is an issue, however, since it's not possible to show a submenu while thickbox is open, due to the overlay. I had to manually add the opensub class to the menu item in order to take the screenshot.

If you had to manipulate in order to make that happen, then no, I wouldn't worry about it. :)

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


6 years ago

#9 @nacin
6 years ago

  • Milestone changed from 3.8.2 to 3.9

So, this patch was going to bring back #26442. (I could reproduce it.) At least until two weeks ago, when Thickbox was dramatically increased to be above distraction-free writing in [27532/trunk/src/wp-includes/js/thickbox/thickbox.css].

So this is no longer an issue. We can bring it back up to 9999 without an issue I can otherwise find. I'll ask avryl to look into this as she has a pretty good grasp on the modals.

#10 @helen
6 years ago

You know, there's a comment on that z-index explaining why it was 9999 before. :)

#11 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 27833:

Restore the original z-index of the sticky admin menu, as first set in [26442].

The inline comment is now correct again. This z-index was changed in [26701], but those circumstances no longer apply after [27532].

props mordauk.
see #26442, #26952.
fixes #26567.

#12 @nacin
6 years ago

Per avryl in IRC: "All modals are above the z-index of the admin bar (99999) now, so 9999 is good."

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


6 years ago

Note: See TracTickets for help on using tickets.