WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#26612 closed defect (bug) (invalid)

CSS z-index issue with system notifications and menu

Reported by: zrodimel Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.8
Component: Administration Keywords:
Focuses: ui Cc:

Description

Just downloaded WP 3.8, looks amazing. One small thing I saw is that the z-index appears to be off for notification messages on the dashboard and the dropdown (sideways) menus. See my attached photo for an example. Great work!

Attachments (1)

Screen Shot 2013-12-13 at 12.04.27 PM.png (27.9 KB) - added by zrodimel 7 years ago.

Download all attachments as: .zip

Change History (15)

#1 @zrodimel
7 years ago

  • Severity changed from normal to minor

#2 @SergeyBiryukov
7 years ago

  • Component changed from Appearance to Administration
  • Keywords ui-focus reporter-feedback added

Related: #26567

Could not reproduce neither on a clean install nor with MP6 2.2.1 activated.

Notification messages like that one don't have a specific z-index set in core.

#3 @MikeHansenMe
7 years ago

Could not reproduce on a clean install either.

#4 @zrodimel
7 years ago

Weird. Must just be me, then. Thanks for looking into it, guys!

#5 @SergeyBiryukov
7 years ago

Could you try with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#6 @JustinSainton
7 years ago

I'm able to reproduce, more or less consistently (oddly, it's not every time.) when switching color schemes on the Profile page. After enough scrolling around and hovering, it fixes itself, which is why it can be hard to catch.

Screenshots: http://d.pr/i/aoWE, http://d.pr/i/nnX9

#7 @JustinSainton
7 years ago

Also interesting. Screenshot on page with Chrome Inspector closed: http://d.pr/i/OYsy

Same page, no settings changed, nothing saved/updated. Chrome Inspector opened: http://d.pr/i/mala

Wondering if it's not something to do with a if( window.console ) check somewhere?

#8 @SergeyBiryukov
7 years ago

  • Keywords reporter-feedback removed

#9 @SergeyBiryukov
7 years ago

#26715 was marked as a duplicate.

#10 @knutsp
7 years ago

I have seen this. I immediately opended the inspector in Firefox and saw the z-index for .updated coming from a Jetpack CSS file. All the above examples include Jetpack. First thing should be to try eliminate Jetpack as the cause. I'm not able to reproduce this on my multisites any longer. After deactivating and reactivating Jetpack I was no longer able to see this.

#11 @SergeyBiryukov
7 years ago

Good catch, the screenshots on #26715 also include Jetpack.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#12 @Chrome Orange
7 years ago

Just tried this, deactivated JetPack and the problem goes away, re-appears when JetPack is reactivated

JetPack is network activated in my case.

#14 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.