WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

#26618 closed defect (bug) (fixed)

iPad comments page does not show commenter name

Reported by: commentluv Owned by: iammattthomas
Milestone: 3.8.1 Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords: has-patch commit fixed-major
Focuses: ui Cc:

Description (last modified by SergeyBiryukov)

When viewing the admin comments page on the iPad, the names of commenters does not show

Attachments (5)

image.jpg (187.6 KB) - added by commentluv 4 months ago.
Admin comments page
26618.patch (1.2 KB) - added by SergeyBiryukov 4 months ago.
26618.after.png (18.8 KB) - added by SergeyBiryukov 4 months ago.
26618.diff (1.4 KB) - added by nacin 3 months ago.
Screen Shot 2014-01-16 at 3.18.06 PM.png (39.4 KB) - added by nacin 3 months ago.

Download all attachments as: .zip

Change History (20)

commentluv4 months ago

Admin comments page

comment:1 SergeyBiryukov4 months ago

  • Component changed from General to Administration
  • Keywords ui-focus added

.column-author is hidden if the screen width is 782px or less: tags/3.8/src/wp-admin/css/wp-admin.css#L12231.

Introduced in [26134], appears to be the expected behaviour.

comment:2 commentluv4 months ago

Expected behaviour? Oh that's a shame because not using a real name is the first thing to check when deciding if a comment will be spammed or not and without the name I can't moderate comments on the ipad properly.

I hope someone realises that the name of the person commenting is more important and needs to be shown, even a small screen!

comment:3 SergeyBiryukov4 months ago

Well, I would expect to always see the name too.

We could probably show it above the "Submitted on" string if there's not enough space for the column.

SergeyBiryukov4 months ago

SergeyBiryukov4 months ago

comment:4 SergeyBiryukov4 months ago

  • Keywords ui-feedback added

26618.patch illustrates the idea: 26618.after.png.

comment:5 SergeyBiryukov4 months ago

  • Keywords has-patch added

comment:6 SergeyBiryukov4 months ago

  • Description modified (diff)
  • Summary changed from Ipad comments page does not show commenter name to iPad comments page does not show commenter name

comment:7 commentluv4 months ago

Good suggestion Sergey, I hope it's in a point release. Thanks!

comment:8 SergeyBiryukov4 months ago

  • Milestone changed from Awaiting Review to 3.9

comment:9 nacin4 months ago

  • Milestone changed from 3.9 to 3.8.1

3.8.1 for consideration.

comment:10 ircbot3 months ago

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.

nacin3 months ago

comment:11 nacin3 months ago

  • Keywords commit added; ui-feedback removed

26618.diff carries over the .column-author styling, and gives it an extra 0.6em margin-bottom (which is the same as the margin between "Submitted on" and the comment below it).

The placement of all of this CSS does not seem ideal, but this otherwise seems good to me.

comment:12 iammattthomas3 months ago

  • Owner set to iammattthomas
  • Resolution set to fixed
  • Status changed from new to closed

In 26961:

The comment screen hides the author column at narrow screen sizes; this adds back the author info above the comment content. Fixes #26618, props SergeyBiryukov, nacin.

comment:13 helen3 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 nacin3 months ago

Fixed for 3.8 in [26962].

comment:15 nacin3 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.