WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#2664 closed defect (bug) (worksforme)

Theme is irregularly reset to the default theme

Reported by: raskall Owned by:
Milestone: Priority: high
Severity: major Version: 2.0.2
Component: Template Keywords: theme reset to default
Focuses: Cc:

Description

Hi

I posted about this in the theme forum and have gotten replies that other people have the same problems. Skippy's (on #wordpress irc channel) also has the same problem. So I guess this qualifies as a bug. But I think it is a 2.0.2-specific thing, because I am the only one on my server with this problem. My wife and two daughters have their blogs on the same server, but are running 2.0.2.

http://wordpress.org/support/topic/68876?replies=6

BTW; I am running vanilla 64-bit Ubuntu breezy with unmodified mysql, php and apache on the server running this blog.


I am running my blog with Wordpress version 2.0.2 and has come across a quite annoying problem. I have found a workaround, but I'd like to find out what the problem is:

I have installed and adapted the Almost Spring 1.0 theme to my blog. Every 2, 3, 4 or x days, the active theme is being reset to the wordpress 1.5 default theme. I have tried stripping away everything I don't need and still it happens.

I think this started when I installed a new, hidden blog in the same database as my regular blog, but with a different database prefix. This new blog has wordpress 1.5 default theme as selected theme.

The workaround I have made is to remove the default theme and copy the Almost spring theme to the default directory and rename the theme in the .css-file. But I don't think this is a satisfactory solution and would like to get a clue of what's doing this.


Change History (6)

comment:1 ryan8 years ago

  • Milestone changed from 2.0.2 to 2.0.4

comment:2 oncidium8 years ago

I have been having the same problem. I have removed all themes except for the one I would like to have as the active theme, so I think that will solve it for the time being.

Odd problem though.

comment:3 doit-cu8 years ago

Has this been debunked by the information in this thread?

http://wordpress.org/support/topic/68876/page/2

comment:4 spencerp8 years ago

I thought Ryan explained the reason in the wp-testers list already? =/ Here's the thread I posted in: http://wordpress.org/support/topic/80523?replies=7

Here's a straight shot to the comment, including the comment by Ryan from the wp-testers list, about it:
http://wordpress.org/support/topic/80523?replies=7#post-415311

I'm not positive for sure, but.. maybe Ryan can shed some light on this then, here. ;) :)

comment:5 foolswisdom8 years ago

  • Milestone 2.0.4 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Marking closed WORKSFORME based on Ryan's explaination on the forums above that reset if the theme did not validate -- which I think I heard may actually now be disabled anyway on trunk.

Note: See TracTickets for help on using tickets.