WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 7 months ago

#26648 closed defect (bug) (duplicate)

Div is not cleared after floated element in /wp-admin/themes.php

Reported by: ankit.gade@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Themes Keywords: has-patch
Focuses: ui, administration Cc:

Description

Div (div.theme-browser) is not cleared after the floated element h2 ( "Themes" heading ). Because of this it will not take any margin or padding properly, if needs to apply in future.
So div.theme-browser needs to be cleared after floated element by adding class "clear".

Attachments (3)

themes1.jpg (170.4 KB) - added by ankit.gade@… 20 months ago.
Screenshot of themes heading
themes2.jpg (152.8 KB) - added by ankit.gade@… 20 months ago.
Screenshot of non cleared div
appearance-themes.patch (277 bytes) - added by ankit.gade@… 20 months ago.
Patch to clear div by adding class clear

Download all attachments as: .zip

Change History (13)

@ankit.gade@…20 months ago

Screenshot of themes heading

@ankit.gade@…20 months ago

Screenshot of non cleared div

@ankit.gade@…20 months ago

Patch to clear div by adding class clear

comment:1 @ankit.gade@…20 months ago

  • Keywords has-patch added

comment:2 @ankit.gade@…20 months ago

  • Cc ankit.gade@… added

comment:3 @SergeyBiryukov20 months ago

  • Keywords ui-focus added

comment:4 @ankit.gade@…20 months ago

  • Version changed from 3.8 to trunk

comment:5 follow-up: @SergeyBiryukov20 months ago

  • Version changed from trunk to 3.8

Version number indicates the earliest affected version.

Because of this it will not take any margin or padding properly, if needs to apply in future.

As long as everything is currently displayed as expected, I don't see this as an issue. If we decide to add a margin or padding in the future, we can add the clear class at the same time.

comment:6 @ankit.gade@…20 months ago

Last edited 20 months ago by ankit.gade@… (previous) (diff)

comment:7 in reply to: ↑ 5 @ankit.gade@…20 months ago

Replying to SergeyBiryukov:

Version number indicates the earliest affected version.

Because of this it will not take any margin or padding properly, if needs to apply in future.

As long as everything is currently displayed as expected, I don't see this as an issue. If we decide to add a margin or padding in the future, we can add the clear class at the same time.

That is fine but it is the css concept that whenever there is an floated element, it should clear immediately just before non-floated element; otherwise its parent container would show height and width as 0px. Also floated element does not occupy space, but its neighbor should start next to that element, in current scenario it is also covering over floated h2 element.

As it is WordPress, we all expect it to follow all the standards. :)

Last edited 20 months ago by ankit.gade@… (previous) (diff)

comment:9 @nacin18 months ago

  • Component changed from Appearance to Themes
  • Focuses administration added

comment:10 @obenland7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26646.

Note: See TracTickets for help on using tickets.