WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#26678 closed defect (bug) (duplicate)

sunrise.php gets included for all values of SUNRISE, including false and 'off'

Reported by: pdclark Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords: has-patch
Focuses: Cc:
PR Number:

Description

The most common example of enabling sunrise.php is to set define( 'SUNRISE', 'on' ); in wp-config.php. Programmers might expect, then, that 'off' would disable it.

Likewise, the standard for other constants, such as WP_DEBUG is true turns it on, false turns it off.

Right now, any value of SUNRISE, including define( 'SUNRISE', false );, includes the file.

Attached patch allows either false or 'off' to disable sunrise.php

Attachments (1)

26678-sunrise.diff (511 bytes) - added by pdclark 6 years ago.
Allow either false or 'off' to disable sunrise.php

Download all attachments as: .zip

Change History (3)

@pdclark
6 years ago

Allow either false or 'off' to disable sunrise.php

#1 @pdclark
6 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 3.0

Duplicate of #20220.

Note: See TracTickets for help on using tickets.