WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

#26690 closed enhancement (maybelater)

Dashboard: show all drafts in Quick Draft area to administrator users

Reported by: lancewillett Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description (last modified by lancewillett)

An admin user on a multi-user blog should be able to see all draft posts on the blog in the Quick Draft area, not just they have authored.

Change History (4)

#1 follow-up: @bcworkz
8 years ago

  • Type changed from defect (bug) to enhancement

Not enumerating draft posts in the "At a Glance" box was a design decision, so this not a bug report but an enhancement request. Even one's own drafts do not appear here, only published posts are shown.

All the draft posts info you are requesting is available on the All Posts Admin Screen.

#2 in reply to: ↑ 1 @helen
8 years ago

Replying to bcworkz:

Not enumerating draft posts in the "At a Glance" box was a design decision, so this not a bug report but an enhancement request. Even one's own drafts do not appear here, only published posts are shown.

I imagine lancewillett was referring to the list of drafts in the Quick Draft box. I would tend to agree that an admin should see everybody's drafts, and perhaps also editors? Or, probably more appropriately, base this on a cap check?

#3 @lancewillett
8 years ago

  • Description modified (diff)
  • Summary changed from Dashboard: show all drafts to administrator users to Dashboard: show all drafts in Quick Draft area to administrator users

Yes, this was regarding the Quick Draft box—sorry for not making it clear in the original description.

#4 @chriscct7
6 years ago

  • Keywords needs-patch added
  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Closing as maybelater. Complete lack of interest on the feature on the ticket over the last 2 years. Feel free to reopen when more interest re-emerges (particularly if there's a patch)

Note: See TracTickets for help on using tickets.