WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#26694 closed defect (bug) (fixed)

Twenty Fourteen: Gap missing above static page using full-width template

Reported by: zoonini Owned by: lancewillett
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Bundled Theme Keywords: has-patch commit fixed-major
Focuses: Cc:

Description

When the full-width template is applied to a page with a featured image, the gap between the featured image and the top black bar is not present, like it is in every other type of view. Example:

https://i.cloudup.com/S45lNAD1WB-3000x3000.png

If a static page with featured image, using full-width template is set as the front page, the gap is present as expected:

https://i.cloudup.com/PIeGeKWhuB-3000x3000.png

Without a featured image the gap is present either way.

Confirmed with Obenland that this is probably a bug.

Reported in: http://wordpress.org/support/topic/twenty-fourteen-featured-image-spacing-on-frontpage

Attachments (3)

26694.diff (347 bytes) - added by ShaneJones 7 years ago.
Addition of style to remove gap above featured images when shown on homepage.
26694.2.diff (1.1 KB) - added by SergeyBiryukov 7 years ago.
26694.3.diff (1.3 KB) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (18)

#1 @obenland
7 years ago

  • Cc iamtakashi added

#2 @iamtakashi
7 years ago

Confirmed. it's a bug and the gap shouldn't be there.

@ShaneJones
7 years ago

Addition of style to remove gap above featured images when shown on homepage.

#3 @ShaneJones
7 years ago

  • Cc ShaneJones added

#4 @ShaneJones
7 years ago

  • Keywords has-patch added

#5 @SergeyBiryukov
7 years ago

The rule added in 26694.diff is already there, so no need to re-add it.

We should just change the selector. Either remove the .singular part, or add another one for .full-width.home. 26694.2.diff goes with the former.

#6 @SergeyBiryukov
7 years ago

26694.3.diff goes with the latter, just in case.

26694.2.diff results in the gap in IE8 due to the next selector (in line 523) not being specific enough:
tags/3.8/src/wp-content/themes/twentyfourteen/css/ie.css#L518

26694.3.diff doesn't have that regression.

#7 @lancewillett
6 years ago

  • Milestone changed from Awaiting Review to 3.8.2

#8 @lancewillett
6 years ago

  • Keywords needs-testing commit added

#9 @seanchayes
6 years ago

For what it's worth, I found that this issue occurred whether the page template was full-width or default.

Nonetheless, when I applied the patch the gap was removed as expected.

This ticket was mentioned in IRC in #wordpress-themes by lancewillett. View the logs.


6 years ago

#11 @lancewillett
6 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 27117:

Twenty Fourteen: fix gap above static pages, props SergeyBiryukov. Fixes #26694.

#12 @lancewillett
6 years ago

  • Keywords needs-testing commit removed

#13 @SergeyBiryukov
6 years ago

  • Keywords commit fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

#14 @timosa
6 years ago

It seems, that the gap is missing between posts too, because featured picture often hides tags of the post above. Tested in wordpress.com with an empty content sidebar.

Last edited 6 years ago by timosa (previous) (diff)

#15 @nacin
6 years ago

  • Milestone changed from 3.8.2 to 3.9
  • Resolution set to fixed
  • Status changed from reopened to closed

lancewillett and I decided that we would be leaving all bundled theme tickets for 3.9. Given the timeline (and lack of severity) we won't be doing a theme update before then.

Note: See TracTickets for help on using tickets.