WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26699 closed defect (bug) (fixed)

Checkboxes for plugin updates not aligned properly

Reported by: mighty_mt Owned by:
Milestone: 3.8.1 Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords: has-patch fixed-major
Focuses: ui Cc:

Description

There is a minor UI bug in the admin that is related to #26489.

In the "Plugins" section under "Dashboard" -> "Updates" the checkboxes in the table are not properly aligned with the ones in the table header/footer. It makes no difference whether or not the listed plugins are activated.
This problem does not exists in the "Themes" section.

I have attached a screenshot to illustrate this.

Reproducible in WordPress 3.8 and 3.9-alpha with Firefox and Internet Explorer (latest version each) on Windows Vista and Windows 7.

Attachments (4)

Bildschirmfoto am 2013-12-21 um 11.13.43.png (45.4 KB) - added by mighty_mt 7 years ago.
26699.diff (869 bytes) - added by morganestes 7 years ago.
Align checkboxes, including responsive widths.
26699.2.patch (1018 bytes) - added by ocean90 7 years ago.
Removed not needed styles
26699-colors.diff (745 bytes) - added by morganestes 7 years ago.
Adds lines to the rows.

Download all attachments as: .zip

Change History (17)

#1 @ocean90
7 years ago

  • Keywords needs-patch ui-focus added
  • Milestone changed from Awaiting Review to 3.8.1

@morganestes
7 years ago

Align checkboxes, including responsive widths.

#2 @morganestes
7 years ago

  • Keywords has-patch added; needs-patch removed

#3 @morganestes
7 years ago

  • Cc morgan.estes@… added

@ocean90
7 years ago

Removed not needed styles

This ticket was mentioned in IRC in #wordpress-dev by ocean90. View the logs.


7 years ago

#5 follow-up: @melchoyce
7 years ago

Looks like it's also missing borders between the plugins: https://cloudup.com/cZ6lwGYUhxC

Those should get added in as well.

#6 @morganestes
7 years ago

@melchoyce They look right in your screenshot, but one is missing in the original screenshot, right?

I've noticed that before in my other installs and assumed the dev did something wonky. Any reason why only some of the borders would disappear and not all of them? If it was all I could easily say it's a CSS issue, but not sure if there's something else going on there.

#7 @melchoyce
7 years ago

@morganestes: I took that screenshot from the plugins page just to demonstrate what it should look like. I'm also seeing the borders missing from both the plugins and themes updates list. I'm guessing it is a css issue, and we just didn't catch it / merge it properly in 3.8.

#8 in reply to: ↑ 5 @ocean90
7 years ago

Replying to melchoyce:

Looks like it's also missing borders between the plugins: https://cloudup.com/cZ6lwGYUhxC

Those should get added in as well.

See tags/3.8/src/wp-admin/css/colors.css#L799.

@morganestes
7 years ago

Adds lines to the rows.

#9 @morganestes
7 years ago

@melchoyce I added a new patch just for the lines. It adds them via box-shadow, and removes the last one so it doesn't clash with the border already set on tfoot.

One thing I noticed is that the HTML output of the updates page applies the .plugins class to both the Plugins and Themes tables, so <tbody class="plugins"> is present inside form[name="upgrade-plugins"] and form[name="upgrade-themes"]. If that changes, this will need to be patched again.

#10 @SergeyBiryukov
7 years ago

  • Keywords fixed-major added

Fixed for trunk in [26935].

#11 @helen
7 years ago

In 26938:

Fix alignment and borders of plugin/theme updates on the Updates screen.

Merges [26935] to the 3.8 branch.

props morganestes, ocean90.
see #26699.

#12 @helen
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

#13 @nacin
7 years ago

In 27023:

3.8 branch: Undo the colors.css changes in [26938] and move the rules to wp-admin.css.

This will prevent us from shipping a full re-build of the color schemes in 3.8.1.

see #26699.

Note: See TracTickets for help on using tickets.