WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 15 months ago

Last modified 15 months ago

#26701 closed defect (bug) (fixed)

Text and RSS Widgets Unusable on Mobile

Reported by: celloexpressions Owned by: azaozz
Milestone: 3.8.1 Priority: normal
Severity: major Version: 3.8
Component: Widgets Keywords: has-patch
Focuses: Cc:

Description

Related: #26117.

Since Text and RSS widgets set a negative margin in order to ensure an arbitrary width (400px), they can become partially hidden at certain viewports below roughly 420px wide. The window can't be scrolled or zoomed out to access the leftmost part of the controls, which can render them completely unusable by the 320px standard smartphone viewport.

I recommend that we just let these default widgets fill the natural width of the sidebar they're in, regardless of viewport, for now. we need a better solution for 3rd party widgets eventually, perhaps removing the width control option or allowing scrolling to view that part of the control.

Attachments (3)

unusable-text-widget.jpg (55.1 KB) - added by celloexpressions 16 months ago.
Screenshot in IE10 Mobile
26701.diff (862 bytes) - added by celloexpressions 16 months ago.
Remove width parameter from text and RSS widget controls, so that they don't overflow and become hidden in small viewports
26701.2.diff (516 bytes) - added by azaozz 15 months ago.

Download all attachments as: .zip

Change History (11)

@celloexpressions16 months ago

Screenshot in IE10 Mobile

@celloexpressions16 months ago

Remove width parameter from text and RSS widget controls, so that they don't overflow and become hidden in small viewports

comment:1 @celloexpressions16 months ago

  • Keywords has-patch added
  • Severity changed from normal to major

comment:2 @SergeyBiryukov16 months ago

  • Milestone changed from Awaiting Review to 3.8.1

@azaozz15 months ago

comment:3 @azaozz15 months ago

Would something like 26701.2.diff work? The problem is there are *huge* widgets added by plugins that don't scale well on very small screens. We shouldn't be breaking these on "normal" sized screens.

comment:4 @celloexpressions15 months ago

26701.2.diff works well since it retains the ideal behavior on larger devices, and should handle 3rd-party widgets well too.

comment:5 @iammattthomas15 months ago

26701.2.diff seems to do the trick quite nicely. I'd commit, but don't know if there are any particular 3rd-party widgets that should be tested first. Azaozz if you think your patch is good to go let's run with it.

comment:6 @ircbot15 months ago

This ticket was mentioned in IRC in #wordpress-dev by azaozz. View the logs.

comment:7 @azaozz15 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 26963:

Widgets: fix scaling of extra-wide widgets on 480px and 320px devices, fixes #26701 for trunk.

comment:8 @azaozz15 months ago

In 26964:

Widgets: fix scaling of extra-wide widgets on 480px and 320px devices, fixes #26701 for 3.8.1.

Note: See TracTickets for help on using tickets.