WordPress.org

Make WordPress Core

Opened 16 months ago

Last modified 16 months ago

#26718 new defect (bug)

Links to some files are broken into pages when importing a wordpress .xml

Reported by: satourne Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 3.8
Component: Import Keywords:
Focuses: Cc:

Description

Hello,

I have a Wordpress hosted blog that I had installed (zip install)... So I export it into a .xml file.
When I go to wordpress.com (3.8 I think...) to a blank blog and if I import that file, links to some files (.pdf) are broken into pages.
Files are really imported but links into pages are broken.

I'm not sure but it's perhaps some links are relatives (/wordpress/...) and not absolute (http://...) .

Great job and thanks again.

Change History (3)

comment:1 follow-up: @Ipstenu16 months ago

Does this happen importing into WordPress.org (i.e. another self hosting site?)

Are all the links that are broken all 'non' WordPress links? That is to files not imported via the media uploader?

(WordPress.com is on 3.9-trunk, so it's a little ahead of 3.8 right now I think...)

comment:2 in reply to: ↑ 1 @satourne16 months ago

Replying to Ipstenu:

Does this happen importing into WordPress.org (i.e. another self hosting site?)

Are all the links that are broken all 'non' WordPress links? That is to files not imported via the media uploader?

(WordPress.com is on 3.9-trunk, so it's a little ahead of 3.8 right now I think...)

  1. I don't know.
  2. Those broken links are all in my wordpress upload path ...
  3. Those files were imported via the media uploader but I remove http prefixes to save some bytes ;), so absolute urls (http://hostname/wordpress/) became relative urls (/wordpress/) ...
  4. I can't find a text with wordpress version at wordpress.com ...

Thanks

comment:3 @Ipstenu16 months ago

It's LIKELY the fact that you removed the http prefixes. I'll have to test that.

The other high possibility is that they're not attached to the post. If you go into Media Uploader, are the images attached to a post? Basically WP can't import it them if they're not attached because it doesn't know the image 'belongs' :/

Note: See TracTickets for help on using tickets.