WordPress.org

Make WordPress Core

#26745 closed defect (bug) (fixed)

Awkward placement of more information plugin screen

Reported by: qBart Owned by: SergeyBiryukov
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Plugins Keywords: has-patch commit
Focuses: ui, administration Cc:

Description

The placement of the 'More information' screen of plugins appears awkward on smaller screens (I have 13 inch). A part gets cut of. It should appear higher, which is also possible, see screenshot.

I'm using OS X 10.9 with Firefox 26.0.

Screenshot: http://cl.ly/image/3f3B0Q0Z143j

Attachments (4)

sceenshot.png (278.5 KB) - added by qBart 16 months ago.
This is the same as the url
Screen Shot 2013-12-30 at 11.29.11.pxm (944.7 KB) - added by qBart 16 months ago.
Safari sceenshot OS X
Screen Shot 2013-12-30 at 11.29.11.png (307.7 KB) - added by qBart 16 months ago.
Safari sceenshot OS X
26745.patch (1.3 KB) - added by SergeyBiryukov 15 months ago.

Download all attachments as: .zip

Change History (18)

@qBart16 months ago

This is the same as the url

comment:1 @SergeyBiryukov16 months ago

  • Component changed from General to Administration
  • Keywords ui-focus added

comment:2 @SergeyBiryukov16 months ago

Could not reproduce in Firefox 26 on Windows.

@qBart16 months ago

Safari sceenshot OS X

@qBart16 months ago

Safari sceenshot OS X

comment:3 @qBart16 months ago

Sorry to hear that.

Safari on OS X has the same problem for me (see png screenshot).

comment:4 @qBart16 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I tried a different WordPress installation, and it worked fine.
Sorry, must be a plugin!

Closing the issue.

comment:5 @ocean9016 months ago

  • Milestone Awaiting Review deleted

comment:6 @sLaNGjI15 months ago

  • Keywords needs-testing needs-patch added
  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi, i am author of plugin mentioned on this issue.

After my test i found that is NOT related to my code but to this class: wp_admin_bar_class

This is the cause of the problem:

add_filter( 'wp_admin_bar_class', '__return_false' );

Read more here http://wordpress.org/support/topic/ui-problem-caused-by-plugin-bug/ Thanks!

Sorry for this ... :)

Last edited 15 months ago by sLaNGjI (previous) (diff)

comment:7 @SergeyBiryukov15 months ago

  • Component changed from Administration to Plugins
  • Focuses administration added
  • Milestone set to Awaiting Review

comment:8 @sLaNGjI15 months ago

Thanks you very much SergeyBiryukov :)

@SergeyBiryukov15 months ago

comment:9 @SergeyBiryukov15 months ago

  • Keywords has-patch commit added; needs-testing needs-patch removed
  • Milestone changed from Awaiting Review to 3.9

So, the plugin removes toolbar in the admin. We don't support that: #19685, #19766.

However, it uncovered a legitimate issue in our thickbox positioning code introduced in [26323].

We use $('body.admin-bar').length to detect toolbar presence, and jQuery('#wpadminbar').css('height') to get its height, so adminbar_height ends up being NaN if #wpadminbar is not present.

We should consistently use #wpadminbar in both places. See 26745.patch.

Last edited 15 months ago by SergeyBiryukov (previous) (diff)

comment:10 @sLaNGjI15 months ago

I have modified this files according patch:

/wp-admin/js/media-upload.js
/wp-admin/js/plugin-install.js
/wp-admin/js/theme.js

Tested on WordPress 3.8.0 and 3.8.1: work for me! (testing is needed from other)

Thanks to SergeyBiryukov :-),

P.S. This is my "first" WordPress Core Bug Ticket ...

Last edited 15 months ago by sLaNGjI (previous) (diff)

comment:11 @sLaNGjI15 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:12 @SergeyBiryukov15 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Tickets are closed when a commit is made to the WordPress trunk.

comment:13 @TobiasBg14 months ago

Looks good, Sergey. Also, jQuery('#wpadminbar') should be changed to $('#wpadminbar') for consistency.

We might even add selector caching, both for $('#wpadminbar') and $(window) in the tb_position functions, but that could go to a new ticket.

comment:14 @SergeyBiryukov14 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 27248:

Fix thickbox positioning if toolbar is not present.

fixes #26745.

Note: See TracTickets for help on using tickets.