WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#26747 closed defect (bug) (fixed)

Can't insert Media (or polls or anything) if using font-icons

Reported by: Ipstenu Owned by: azaozz
Milestone: 3.9 Priority: normal
Severity: critical Version: 3.9
Component: Editor Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

Inserts (like media or polls or anything NOT on the toolbar) all fail ... if you have a font-icon set install.

I can reproduce it with Genericon'd (my genericons plugin) and Font-Awesome (be it via the plugin or a font). This INCLUDES Twenty Thirteen. Which has Genericons.

Possibly related to #24067 ? Not sure. To reproduce just install WP trunk and then activate TwentyThirteen. Try to add images.

I was able to reproduce this on three installs, including local.

Change History (6)

#1 @Ipstenu
6 years ago

  • Keywords needs-patch added
  • Severity changed from normal to critical

#2 in reply to: ↑ description @Ipstenu
6 years ago

Replying to Ipstenu:

(be it via the plugin or a font)

That should be 'be it a plugin or in a theme' ... I'm tired, Bob.

#3 follow-up: @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 3.9

Reproduced in Text editor on page load. The AJAX request seems to run successfully, but nothing appears in the editor.

Works for me after switching to Visual editor and back. Could not reproduce in Visual editor.

#4 in reply to: ↑ 3 @SergeyBiryukov
6 years ago

Replying to SergeyBiryukov:

Reproduced in Text editor on page load. The AJAX request seems to run successfully, but nothing appears in the editor.

Happens with both Twenty Thirteen and Twenty Fourteen.

#5 @azaozz
6 years ago

Confirmed. Happens only in the Text editor because the JS global wpActiveEditor is not set on page load before the Quicktags toolbar is used. Fix coming up.

Last edited 6 years ago by azaozz (previous) (diff)

#6 @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 26881:

Set wpActiveEditor as soon as any editor associated button is clicked, including Add Media, switching Text to Visual, etc. Fixes #26747.

Note: See TracTickets for help on using tickets.