WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26762 closed defect (bug) (invalid)

Visual Editor Strips Shortcode Attributes When Pasting

Reported by: cliffseal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: TinyMCE Keywords:
Focuses: Cc:

Description

In Visual mode, pasting a shortcode with attributes, like[myshortcode attribute="this", strips the attributes, so that only [myshortcode] is pasted.

It appears to strip them out on paste, as it works in Text mode, and copying from Text mode, switching to Visual, then pasting doesn't work, either.

Change History (7)

#1 @iseulde
7 years ago

I'm pasting [myshortcode attribute="this"] in the visual editor and it works in 3.8.

#2 @jdgrimes
7 years ago

  • Keywords reporter-feedback added

I'm unable to reproduce this on 3.8 or on trunk. Can you give some more details, like what browser you are using, and where the text was originally copied from? Also try deactivating any plugins that might be causing this.

#3 @azaozz
7 years ago

Works for me in both 3.8 and trunk (TinyMCE 3.5 and 4.0).

#4 @cliffseal
7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

This is obviously not a WordPress bug, it just happened to me in several different environments. Must be a common denominator. Thanks, everyone, for testing.

#5 @cliffseal
7 years ago

  • Keywords reporter-feedback removed

#6 @SergeyBiryukov
7 years ago

  • Component changed from Editor to TinyMCE
  • Milestone Awaiting Review deleted
  • Resolution changed from worksforme to invalid

#7 @jphogan
7 years ago

I wanted to +1 this issue. It is happening to be as well. If I use ctrl+shift+v to paste without formatting, it works.

Note: See TracTickets for help on using tickets.