Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26770 closed defect (bug) (invalid)

upgrade to 3.8 - media library & set featured image do not load media

Reported by: qwertyjjj's profile qwertyjjj Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Media Keywords:
Focuses: Cc:

Description

I upgraded to 3.8, I cannot now upload media into the media library.
It looks like it is uploading but then when it has finished, the image just appears grey.

I am using Servage not GoDaddy, it seems to be the same problem as many other users are having.
Any ideas what to do?

I have tried:
1/ deactivating all plugins
2/ switching to the Twenty Eleven theme but same problem
3/ resetting the plugins folder by FTP

Something must have changed in WordPress

Change History (30)

#1 @SergeyBiryukov
10 years ago

  • Component changed from General to Media

#2 follow-up: @markoheijnen
10 years ago

Many other users are??? Do you receive any errors?

#3 in reply to: ↑ 2 @qwertyjjj
10 years ago

Replying to markoheijnen:

Many other users are??? Do you receive any errors?

Other users from looking through the forums. If you search "3.8 upgrade media upload problem", there are quite a few posts.

There are no errors. It completes but the image remains grey and no image is displayed as the featured image for the post.

Last edited 10 years ago by qwertyjjj (previous) (diff)

#4 follow-up: @markoheijnen
10 years ago

I clicked a few and those aren't related to this issue. For what I can tell it seems an hosting issue.
And with errors I mean PHP errors what WordPress normally hides. Do you have some server software information? Like which version of GD and/or Imagick it runs on.

Did you also tried different kind of images?

#5 in reply to: ↑ 4 @qwertyjjj
10 years ago

Replying to markoheijnen:

I clicked a few and those aren't related to this issue. For what I can tell it seems an hosting issue.
And with errors I mean PHP errors what WordPress normally hides. Do you have some server software information? Like which version of GD and/or Imagick it runs on.

Did you also tried different kind of images?

It worked in 3.7, as soon as I upgraded it stopped so seems likely something in Wordpress changed or the new wordpress doesn't work with this GD version?
https://www.google.com/search?q=3.8+set+featured+image+problem#q=3.8+cannot+upload+media

wp-content/uploads and all subsequent folders are 755
no anti hotlinking on server

GD info:
array(12) { ["GD Version"]=> string(26) "bundled (2.1.0 compatible)" ["FreeType Support"]=> bool(true) ["FreeType Linkage"]=> string(13) "with freetype" ["T1Lib Support"]=> bool(false) ["GIF Read Support"]=> bool(true) ["GIF Create Support"]=> bool(true) ["JPEG Support"]=> bool(true) ["PNG Support"]=> bool(true) ["WBMP Support"]=> bool(true) ["XPM Support"]=> bool(false) ["XBM Support"]=> bool(true) ["JIS-mapped Japanese Font Support"]=> bool(true) }

Same error for PNG and JPG files

Turned on debug I get:

Error schema patin.png An error occurred in the upload. Please try again later.

Last edited 10 years ago by SergeyBiryukov (previous) (diff)

#6 follow-up: @markoheijnen
10 years ago

I can't reproduce the issue you are having.

#7 in reply to: ↑ 6 @qwertyjjj
10 years ago

Replying to markoheijnen:

I can't reproduce the issue you are having.

So, what's the next step?
An error is being reported on Wordpress (not a very useful error as it doesn't give the code line and because it's a sort of popup screen (Media upload), there are no page php errors.

Other people have a similar issue.

Is my GD compatible with wordpress 3.8?

#8 follow-up: @markoheijnen
10 years ago

I didn't find someone with the exact same issue. You are the first as far as I can find that gets grey images.

As far as I can see is that you need to contact your hosting. You could log PHP errors in a file that will maybe give us some more information.

The GD version is the same as mine except the array you are passing does miss some version numbers I do have. No clue it that can lead to this issue. Also I'm running PHP 5.5.7 and don't have any issues. Maybe your GD is custom compiled.

#9 in reply to: ↑ 8 @qwertyjjj
10 years ago

Replying to markoheijnen:

I didn't find someone with the exact same issue. You are the first as far as I can find that gets grey images.

As far as I can see is that you need to contact your hosting. You could log PHP errors in a file that will maybe give us some more information.

The GD version is the same as mine except the array you are passing does miss some version numbers I do have. No clue it that can lead to this issue. Also I'm running PHP 5.5.7 and don't have any issues. Maybe your GD is custom compiled.

Some more posts:
https://www.google.com/search?q=3.8+gray+image+media+upload

My php info shows php 5.4.42, I cannot upgrade further.

imagick:

imagick module	enabled
imagick module version 	3.1.0RC2
imagick classes 	Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
ImageMagick version 	ImageMagick 6.7.8-7 2013-01-11 Q16 http://www.imagemagick.org
ImageMagick copyright 	Copyright (C) 1999-2012 ImageMagick Studio LLC
ImageMagick release date 	2013-01-11
ImageMagick number of supported formats: 	206
ImageMagick supported formats 	3FR, A, AAI, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FITS, FRACTAL, FTS, G, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, J2C, J2K, JNG, JP2, JPC, JPEG, JPG, JPX, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAP, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG24, PNG32, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RGB, RGBA, RGBO, RLA, RLE, SCR, SCT, SFW, SGI, SHTML, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VST, WBMP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV

Directive	Local Value	Master Value
imagick.locale_fix	0	0
imagick.progress_monitor	0	0
Last edited 10 years ago by SergeyBiryukov (previous) (diff)

#10 @markoheijnen
10 years ago

I'm not going to read a Google search page since the first result for me is already wrong and the second is yours ;).

Ah, so I guess you are using Imagick then instead of GD for resizing images. Can you test out this plugin: https://github.com/getsource/default-to-gd. That one will use GD as the default editor.

#11 @markoheijnen
10 years ago

In that case it seems to be an ImageMagick issue since I'm also using the same Imagick version but not Imagemagick one. Mine is a bit older

#12 @qwertyjjj
10 years ago

Installed and activated the plugin but I get the same issue, same error.

#13 follow-up: @markoheijnen
10 years ago

I don't think I can help you out with the information I got now. For now it's something you need to figure out with your hosting.

#14 in reply to: ↑ 13 @qwertyjjj
10 years ago

Replying to markoheijnen:

I don't think I can help you out with the information I got now. For now it's something you need to figure out with your hosting.

It seems highly coincidental that on upgrading to 3,8 it just stops working!!!!!
How can I downgrade to 3.7 without breaking things?

#15 follow-up: @markoheijnen
10 years ago

Using a lot of exclamation marks doesn't really help. Also did you tried uploading an image just before upgrade and just after upgrade? We didn't change this code that much during this release.

You can easily downgrade to 3.7. It shouldn't break a thing but it can happen since we don't test that.

#16 in reply to: ↑ 15 @qwertyjjj
10 years ago

Replying to markoheijnen:

Using a lot of exclamation marks doesn't really help. Also did you tried uploading an image just before upgrade and just after upgrade? We didn't change this code that much during this release.

You can easily downgrade to 3.7. It shouldn't break a thing but it can happen since we don't test that.

To be fair...neither does writing "I can't recreate your error" and nothing else :)
Other people have the same issue - many similar posts in the troubleshooting forum.
Thanks for the help so far - I will downgrade, I think that is easier...the host will not help since they will say this is a Wordpress issue.

#17 @markoheijnen
10 years ago

That does help. If I could reproduce the error then it's sure that there is an issue in WordPress. Because I couldn't reproduce it, there is a good change this could be a server issue.

As said before I don't see that other people having issues. If you have a forum topic or any other direct link to a particular issue then I'm more then happy to look into that.

I would ask the hosting anyway since downgrading isn't the solution but if you don't want to find a solution than that is fine for me.

#18 follow-up: @qwertyjjj
10 years ago

it seems to be a thumbnails issue.
If I upload and browse to the file in the media library and edit it I can see it but there are no thumbnails and no featured image.
It also does not appear in the wp-content/uploads/2014/01 folder so where has it been stored instead?

Last edited 10 years ago by qwertyjjj (previous) (diff)

#19 @markoheijnen
10 years ago

That does seem like a file permission issue.

#20 follow-up: @markoheijnen
10 years ago

I did wrote a small debug tool: https://github.com/markoheijnen/Debug-Image-editors. It will check both editors WordPress has and shows images. If it goes wrong it will return the output of WP_Image_Editor.

#21 in reply to: ↑ 18 ; follow-up: @bjornjohansen
10 years ago

Replying to qwertyjjj:

it seems to be a thumbnails issue.
If I upload and browse to the file in the media library and edit it I can see it but there are no thumbnails and no featured image.
It also does not appear in the wp-content/uploads/2014/01 folder so where has it been stored instead?

Can you browse to the file in the media library where you can see it, right click it and select to view it in new tab (the menu option might only be in Chrome)? The goal is to find the URL to the image you actually can see.

I'm also guessing it might be a file permission issue, but you really need to provide some more debugging info here.

#22 in reply to: ↑ 20 @qwertyjjj
10 years ago

Replying to markoheijnen:

I did wrote a small debug tool: https://github.com/markoheijnen/Debug-Image-editors. It will check both editors WordPress has and shows images. If it goes wrong it will return the output of WP_Image_Editor.

thanks.
this is the output (all text):
Current image editor
WP_Image_Editor_Imagick

WP_Image_Editor_Imagick
example1
example2
example3
example4

WP_Image_Editor_GD
example1
example2
example3
example4

Last edited 10 years ago by qwertyjjj (previous) (diff)

#23 in reply to: ↑ 21 @qwertyjjj
10 years ago

Replying to bjornjohansen:

Replying to qwertyjjj:

it seems to be a thumbnails issue.
If I upload and browse to the file in the media library and edit it I can see it but there are no thumbnails and no featured image.
It also does not appear in the wp-content/uploads/2014/01 folder so where has it been stored instead?

Can you browse to the file in the media library where you can see it, right click it and select to view it in new tab (the menu option might only be in Chrome)? The goal is to find the URL to the image you actually can see.

I'm also guessing it might be a file permission issue, but you really need to provide some more debugging info here.

in the edit page, it gives the url as:
http://www.mysite.com/wp-content/uploads/2014/01/schema-patin.png

however, on loading that page there is no content.

if I Edit-->Edit Image, it appears but link location is:
http://www.mysite.com/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=515079ef22&postid=403&rand=16306

Last edited 10 years ago by qwertyjjj (previous) (diff)

#24 follow-up: @markoheijnen
10 years ago

Last one is a stream and does that from the original. I have no clue what is going on but I'm sure it's an server issue.

#25 in reply to: ↑ 24 @qwertyjjj
10 years ago

Replying to markoheijnen:

Last one is a stream and does that from the original. I have no clue what is going on but I'm sure it's an server issue.

is your plugin supposed to output images or is it currently correct?
Interestingly, if I create a new wordpress site in 3.8, the media upload works correctly (on the same host)

Last edited 10 years ago by qwertyjjj (previous) (diff)

#26 follow-up: @bjornjohansen
10 years ago

Can you install the plugin ServerBuddy (http://wordpress.org/plugins/serverbuddy-by-pluginbuddy/) and check that all entries under the File Permissions section are OK/green (you'll find it under Tools in the menu)?

#27 in reply to: ↑ 26 @qwertyjjj
10 years ago

Replying to bjornjohansen:

Can you install the plugin ServerBuddy (http://wordpress.org/plugins/serverbuddy-by-pluginbuddy/) and check that all entries under the File Permissions section are OK/green (you'll find it under Tools in the menu)?

Everything shows up green

#28 @qwertyjjj
10 years ago

I upgraded an alternative site to 3.8 on the same server and it was fine, the media upload works correctly.
So, what else can I do on my current site?
I have deactivated all plugins and tried the template themes and nothing works.
All the permissions are correct.
So, I am only left with a database problem, a plugin problem, or something strange on 1 specific hosting server. The fact that I re-installed Wordpress with a blank 3.8 and it worked seems to imply it's still the plugins or database?

#29 @qwertyjjj
10 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

And guess what it was...
an incorrect setting in the database after migrating the site. The db still had a reference to the old site!
Arggh.

Thanks all for the help.

#30 @SergeyBiryukov
10 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.