WordPress.org

Make WordPress Core

#26782 closed defect (bug) (fixed)

Twenty Fourteen: Sidebar links are not clickable on narrow 2-column layout

Reported by: Nao Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Bundled Theme Keywords: has-patch commit fixed-major
Focuses: Cc:

Description

Issue summary:
The links contained in the right sidebar div become un-clickable when:

  • the window width is less than 1008px
  • #content-sidebar div height is greater than that of .site-content div
  • the sidebar links appear above the height of the content div

This issue happens on the home page or static pages, but not on single post or archive pages.

Steps for reproduction:

  • Set "Blog pages show at most" to "1" on Reading Settings screen.
  • Add widgets to the right sidebar so that the sidebar becomes taller than the post content area
  • Set the window width between 673-1007 px
  • Try clicking the sidebar link - the cursor will not change to finger icon as it supposed to

Tested on Chrome 31/ Safari 7 on Mac 10.9
Originally reported on http://ja.forums.wordpress.com/topic/1159?replies=1

Attachments (1)

26782.diff (400 bytes) - added by celloexpressions 16 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 @MikeHansenMe16 months ago

  • Keywords reporter-feedback added

Looks to me like the #content-sidebar is at the same level as #primary and that .site-content should not have an effect on #content-sidebar. I tested this on FF26 and Chrome 31 on Ubuntu. Could you provide us with your browser/OS so we can look into this problem more?

comment:2 @celloexpressions16 months ago

  • Keywords has-patch needs-testing added; reporter-feedback removed

Confirmed with Chrome 32 on Windows 8.1. Not an issue in Firefox or IE.

More specifically, when the content area is shorter than the sidebar in those viewpoints, the z-index of the .content-area (which is full-width) appears to be above that of .content-sidebar, so it isn't possible to interact with them (by selecting text, clicking links, etc.). An exception is the post meta links in the ephemera widgets.

This is most likely a Chrome/Webkit bug, but setting the positioning of .content-sidebar seems to fix it.

@celloexpressions16 months ago

comment:3 @lancewillett16 months ago

  • Milestone changed from Awaiting Review to 3.9

comment:4 @lancewillett16 months ago

  • Milestone changed from 3.9 to 3.8.2

comment:5 @lancewillett16 months ago

  • Keywords commit added

comment:6 @Nao15 months ago

I applied the change in the patch and confirmed the issue is fixed.

comment:7 @lancewillett15 months ago

In 27121:

Twenty Fourteen: fix unreachable links when the content area is shorter than the sidebar in smaller viewpoints. Props celloexpressions, see #26782.

comment:8 @lancewillett15 months ago

  • Keywords fixed-major added; needs-testing removed

comment:9 @nacin13 months ago

  • Milestone changed from 3.8.2 to 3.9
  • Resolution set to fixed
  • Status changed from new to closed

lancewillett and I decided that we would be leaving all bundled theme tickets for 3.9. Given the timeline (and lack of severity) we won't be doing a theme update before then.

Note: See TracTickets for help on using tickets.