WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26792 closed defect (bug) (worksforme)

Tests_HTTP_curl::test_file_stream - Failed

Reported by: kworthington Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: HTTP API Keywords:
Focuses: Cc:

Description

To reproduce:
Get revision 26918.

run:

phpunit

Output:

1) Tests_HTTP_curl::test_file_stream
Failed asserting that true is false.

/var/www/public_html/testsite.com/wordpress-develop/tests/phpunit/tests/http/base.php:187

When running in safe mode, the test passes:

phpunit -d safe_mode=on --group http

Change History (5)

#1 @kworthington
7 years ago

I just re-ran it (phpunit) after running without, and then with safe mode, and I didn't get the error.

May be invalid or worksforme for someone else.

#2 @kworthington
7 years ago

  • Keywords 2nd-opinion added

#3 @kworthington
7 years ago

  • Keywords 2nd-opinion removed

#4 @dd32
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Because the HTTP tests rely on remote HTTP requests, they're known to fail occasionally, but work on a 2nd run, nothing to do with failing code but rather a failed network connection, unfortunately we can't really detect which one it is I don't think.

If it worked for you on a 2nd pass, I'm inclined to believe it was a temporary network glitch. re-open if it's still occurring reliably for you

#5 @kworthington
7 years ago

Sounds good. Thanks for clarifying.

Note: See TracTickets for help on using tickets.