Make WordPress Core

Opened 10 years ago

Closed 7 years ago

#26914 closed defect (bug) (duplicate)

False update notifications in a localised version of WordPress

Reported by: petya-r's profile Petya R Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Ever since 3.8 on the sites where I run a localised version of WordPress, I get a false update notification that 3.8 is available and I need to update now.

All the sites this happens to have been updated to 3.8 the moment the version came out.

What happens:

  • I login to the admin
  • I see a notification that 3.8 is available
  • I click on the Update now link
  • I go to the updates page where I read that my site's up to date

The notification shows up every once in a while, disappears after I visit the update page and then a couple of days later is back again.

Here's a screencast to illustrate the issue: https://cloudup.com/cqp2G24P4vz

Here's a screenshot from the network administration: https://www.dropbox.com/s/agekksdeii814kj/Screenshot%202014-01-23%2011.34.32.png

I don't think it's a multisite problem because it has occurred with a normal single installation too.

The only common denominator that I can find between the sites where this issue occurs is i18n. All of them run the bg_BG version of WordPress.

The multisite where I demonstrate the issue on has both English and Bulgarian WordPress installed.

It also has Admin in English activated for the Bulgarian site.

Change History (4)

#1 @nacin
10 years ago

  • Keywords reporter-feedback added

Hi Petya! Welcome :)

When you go back to the dashboard, I presume you no stop seeing the nag?

Is an external object cache (wp-content/object-cache.php) in use? If not:

Next time you see this, can you provide the value of the _site_transient_update_core option from the database? It'll be a massive chunk of serialized PHP. (In single site, wp_options. Multisite, consult sitemeta.) You'll have to do it before you go to the Updates screen. Then do go to that Screen and check the value again, and provide that too.

If we can see what data is getting stored and interpreted, we should be able to track down what is happening. More information that will assist is whether you're running just the Bulgarian locale or also the localized package. If the latter, there will be a $wp_local_package variable in version.php.

I will try to flag down the other I18n expert, nbachiyski, as well.

#2 @Petya R
10 years ago

Hello :)

Thanks, it's been long overdue. Hope I'll be able to help.

Yep, the notification disappears once I go back to the Dashboard.

I can't find wp-content/object-cache.php, but we've got wp-content/advanced-cache2.php, probably a leftover from the W3 Total Chache plugin who we no longer use. Perhaps it was overwritten?

Here's the value of _site_transient_update_core before and after going to the update page.

Before with the nag active:

O:8:"stdClass":4:{s:7:"updates";a:1:{i:0;O:8:"stdClass":10:{s:8:"response";s:7:"upgrade";s:8:"download";s:49:"http://bg.wordpress.org/wordpress-3.8.1-bg_BG.zip";s:6:"locale";s:5:"bg_BG";s:8:"packages";O:8:"stdClass":5:{s:4:"full";s:49:"http://bg.wordpress.org/wordpress-3.8.1-bg_BG.zip";s:10:"no_content";b:0;s:11:"new_bundled";b:0;s:7:"partial";b:0;s:8:"rollback";b:0;}s:7:"current";s:5:"3.8.1";s:7:"version";s:5:"3.8.1";s:11:"php_version";s:5:"5.2.4";s:13:"mysql_version";s:3:"5.0";s:11:"new_bundled";s:3:"3.8";s:15:"partial_version";s:0:"";}}s:12:"last_checked";i:1390887569;s:15:"version_checked";s:5:"3.8.1";s:12:"translations";a:0:{}}

After with the nag gone:

O:8:"stdClass":4:{s:7:"updates";a:1:{i:0;O:8:"stdClass":10:{s:8:"response";s:6:"latest";s:8:"download";s:41:"https://wordpress.org/wordpress-3.8.1.zip";s:6:"locale";s:5:"en_US";s:8:"packages";O:8:"stdClass":5:{s:4:"full";s:41:"https://wordpress.org/wordpress-3.8.1.zip";s:10:"no_content";s:52:"https://wordpress.org/wordpress-3.8.1-no-content.zip";s:11:"new_bundled";s:53:"https://wordpress.org/wordpress-3.8.1-new-bundled.zip";s:7:"partial";b:0;s:8:"rollback";b:0;}s:7:"current";s:5:"3.8.1";s:7:"version";s:5:"3.8.1";s:11:"php_version";s:5:"5.2.4";s:13:"mysql_version";s:3:"5.0";s:11:"new_bundled";s:3:"3.8";s:15:"partial_version";s:0:"";}}s:12:"last_checked";i:1390896175;s:15:"version_checked";s:5:"3.8.1";s:12:"translations";a:0:{}}

It doesn't seem like we're running the localized package or at least I couldn't find $wp_local_package in version.php.

Cheers!

#3 @xmeltrut
9 years ago

I'm seeing the same issue on WordPress 4.2.2–en_GB. I was running 4.2.2, then I added the translation pack, and now it tells me I have an update. But when I go to the update page it tells me everything is up-to-date. Doing a re-install made no difference.

#4 @ocean90
7 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29528.

Note: See TracTickets for help on using tickets.