WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#26925 closed enhancement (duplicate)

Add native version checks (php, core, multisite) for plugins

Reported by: cfoellmann Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Plugins Keywords:
Focuses: Cc:

Description

Additional core plugin headers for compatibility filtering on plugin.php.
Fully optional like Network: True

Headers:

$plugin_data['Core'] // The minimum WordPress version required.
$plugin_data['PHP'] // The minimal PHP version required.

Additional view on plugins.php:

plugins.php?plugin_status=incompatible // listing all incompatible plugins (removed from ?plugin_status=all)

DONE:

  • ADDED headers: Core, PHP, Multisite
  • ADDED checks for headers values: is_plugin_compatible() + separate checks for the three single headers
  • ADDED view "incompatible" to plugins.php
  • UNSET incompatible plugins from view "all"
  • ADDED option to "Delete" plugin on view "incompatible"

TODO:

  • ADD function to remove incompatible plugins from mu-plugins loading
  • ADD display of compatibility issues details for each single plugin

Direct checkout: https://github.com/cfoellmann/WordPress/tree/headers
Patch(es): Attached

Attachments (1)

0001-add-plugin-headers-Core-PHP-and-functions-to-check-a.patch (14.5 KB) - added by cfoellmann 8 years ago.
patch-0.1

Download all attachments as: .zip

Change History (3)

#1 @jdgrimes
8 years ago

Looks like this might be a duplicate of #26909.

#2 @jeremyfelt
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Agreed, and has a patch as well.

I think this is great progress, @cfoellmann. Can you add a comment and your patch to #26909 for further discussion there?

Note: See TracTickets for help on using tickets.