WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#26938 closed defect (bug) (invalid)

3.8.1 auto update caused white screen - deleted most of functions.php

Reported by: jtf1117 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

My site was auto updated yesterday to 3.8.1 and it resulted in a white screen of death.

I went into debug mode and it referred to line 214 of functions.php. That ended up being the last line of functions.php, so the other ~3900 lines were gone.

I fixed it by copying over functions.php from another 3.8.1 install and then re-running the 3.8.1 upgrade.

Site is http://albanydigitalservices.com

Thank you.

Change History (3)

#1 @nacin
4 years ago

jtf1117, there's no record of that site receiving an auto-update. Did your install email you? Do you have a managed WordPress hosting service?

Is there anything in any PHP error logs? It's highly unlikely that the script died due to memory or other issues, especially since the reinstall went fine.

#2 @jtf1117
4 years ago

Well it definitely did update because the WP folders and files showed last modified on 1/24/2014, when the last time I ran any updates was on 1/8/2014.

When I copied over functions.php, the message that an auto update has failed appeared. I re-updated it and all was fine.

I do not have a managed hosting service. I run InfiniteWP but that requires admin interaction and I last used it on 1/8.

I did not get an email from my site about this one updating. I did get one from other sites that auto updated fine.

The only error was this one, which ended when I re-updated on 1/25. It started at 13:09:09 UTC on 1/24.
[24-Jan-2014 13:09:09 UTC] PHP Parse error: syntax error, unexpected end of file in /home/jtfila/public_html/wp-includes/functions.php on line 214

Jeff

Last edited 4 years ago by jtf1117 (previous) (diff)

#3 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Although we do take failures such as this seriously, unfortunately without further reports of the issue or the ability to duplicate it, there's very little to do here.

We've been continuously improving the update processes, and hopefully one of those will fix whatever happened in your case.

I'm marking this ticket as invalid for now until something shows up to confirm it as a reproducible bug.

Note: See TracTickets for help on using tickets.