WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#26945 closed feature request (wontfix)

A feature to uninstall plugins that leave remnants behind

Reported by: Sjourney Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Plugins Keywords:
Focuses: Cc:
PR Number:

Description

Sort of like how App Zapper or App Trap work on OSX. An uninstaller that completely removes any content left behind by a plugin. Just noticed my database has some crud in it that shouldn't be there anymore.

Change History (3)

#1 @jdgrimes
6 years ago

It is true that many plugins leave behind lots of crud. The plugin API allows plugins to uninstall themselves before they are deleted. The problem is that many of them don't. While a universal uninstaller seems like a good idea, it would be difficult to identify the database contents with particular plugins. I think it is better left up to the plugin developer, as they know what options and metadata belong to their plugin. A plugin that would help with manual database cleaning would be nice. There are probably some plugins like that already, though.

#2 @nacin
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Yeah, unfortunately, this is just not feasible for core. Too many edge cases and ambiguity. That said it could make an interesting plugin in and of itself.

#3 @netweb
4 years ago

#33194 was marked as a duplicate.

Note: See TracTickets for help on using tickets.