WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#26964 closed enhancement (worksforme)

Support https URLs in Twitter embeds

Reported by: mattheweppelsheimer Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Embeds Keywords: reporter-feedback
Focuses: Cc:

Description

In WP 3.8.1, URLS to embed tweets in posts only work with the http protocol. They fail with https. I find this to be counterintuitive, since all of twitter.com seems to be served through https.

I realize we are limited by Twitter's APIs, but it seems it should be possible to support both. If Twitter's API requires https, perhaps the embed detection code can do the conversion before sending the request.

First time reporter. I sure hope I'm doing this right! ;-)

FYI I reviewed all discussion of #26844 and didn't see mention of this.

Change History (5)

#1 in reply to: ↑ description @mattheweppelsheimer
8 years ago

Replying to mattheweppelsheimer:

I realize we are limited by Twitter's APIs, but it seems it should be possible to support both. If Twitter's API requires https, perhaps the embed detection code can do the conversion before sending the request.

Right, I meant "If Twitter's API requires http, …".

#2 @ericmann
8 years ago

  • Keywords reporter-feedback added

I just tested this on a live 3.8.1 site and can't reproduce it. Great report, though, but perhaps a list of what theme you're using and plugins and such would help clarify what's going on.

#3 @ocean90
8 years ago

If Twitter's API requires https, perhaps the embed detection code can do the conversion before sending the request.

Which we currently do, see tags/3.8.1/src/wp-includes/class-oembed.php#L49.

#4 @ericmann
8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

#5 @TobiasBg
8 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.