WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#26970 closed defect (bug) (duplicate)

Regex error in url_to_postid()

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: General Keywords:
Focuses: Cc:

Description

When a rewrite rule contains a negative look-ahead (don't ask…), one of the regex used in url_to_postid() breaks.

The attached patch changes the delimiters to something that won't appear in a url.

Attachments (2)

26970.diff (497 bytes) - added by Denis-de-Bernardy 4 years ago.
26970.2.diff (634 bytes) - added by Denis-de-Bernardy 4 years ago.
fix the actually problematic regex

Download all attachments as: .zip

Change History (5)

@Denis-de-Bernardy
4 years ago

fix the actually problematic regex

#1 follow-up: @nacin
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23587, looks like, which seems to patch both of these. If we can figure out which is appropriate (one or the other or both) I'm happy to fix this. Assuming we can't think of anything it would break. See also #12271.

#2 in reply to: ↑ 1 @Denis-de-Bernardy
4 years ago

Replying to nacin:

Duplicate of #23587, looks like, which seems to patch both of these. If we can figure out which is appropriate (one or the other or both) I'm happy to fix this. Assuming we can't think of anything it would break. See also #12271.

@nacin: See my answer in #23587

This ticket was mentioned in IRC in #wordpress-dev by ddebernardy. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.