Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26991 closed enhancement (duplicate)

Allowing custom post types in count_user_posts

Reported by: danielpataki's profile danielpataki Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: General Keywords:
Focuses: Cc:

Description

While making a plugin I needed to count the custom post types created by a user. As I was looking at the count_user_posts() function it occurred to me that it doesn't allow for custom post types. I've attached a quick fix for this. This is my second time submitting and I haven't received a reply for the first one yet so if I'm using an incorrect format do let me know!

Thanks,

Daniel

Attachments (1)

user-mine.patch (250 bytes) - added by danielpataki 10 years ago.
A quick patch to add custom post type support to count_user_posts()

Download all attachments as: .zip

Change History (4)

@danielpataki
10 years ago

A quick patch to add custom post type support to count_user_posts()

#1 @ocean90
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21364.

#2 in reply to: ↑ description @ocean90
10 years ago

Replying to danielpataki:

This is my second time submitting and I haven't received a reply for the first one yet so if I'm using an incorrect format do let me know!

Hey danielpataki,
thanks so far for your contributions!
Sadly the diff has not the correct format. Just take a look at our handbook: http://make.wordpress.org/core/handbook/submitting-a-patch/

#3 @danielpataki
10 years ago

Thanks, sorry about that! I searched the trac but didn't find anything, although this probably reflects poorly on my searching capabilities :)

Also, thanks for the link, I will give it a read and submit in the proper fashion next time!

Daniel

Note: See TracTickets for help on using tickets.